Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cannot get VLANs across wireless bridge. Need Help Please!

I have 2 2950 switches and 2 1200 access points. I upgraded the ios to allow me to use them as bridges. I have the bridge setup just fine. I have created two vlans (1 and 5). I have them plugged into the switches and have the ports configured for switchport mode trunk. I cannot seem to get the vlan portion for work correctly. Can somebody please help. I have researched and researched and tried multiple things but nothing seems to works. Here is one of my access points.

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname AP1

!

enable secret xxx

!

ip subnet-zero

!

!

no aaa new-model

!

dot11 ssid vlan1

vlan 1

infrastructure-ssid

!

dot11 ssid vlan5

vlan 5

!

dot11 network-map

!

!

username Cisco password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid vlan1

!

ssid vlan5

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root access-point

rts threshold 2312

antenna receive right

antenna transmit right

antenna gain 3

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.5

encapsulation dot1Q 5

no ip route-cache

bridge-group 5

bridge-group 5 subscriber-loop-control

bridge-group 5 block-unknown-source

no bridge-group 5 source-learning

no bridge-group 5 unicast-flooding

bridge-group 5 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

hold-queue 160 in

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.5

encapsulation dot1Q 5

no ip route-cache

bridge-group 5

no bridge-group 5 source-learning

bridge-group 5 spanning-disabled

!

interface BVI1

ip address 192.168.1.1 255.255.255.0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

line vty 5 15

login

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

I got mine working.

In the switch I issued the command

no spanning-tree vlan 50,98

Give it a try and let me know.

18 REPLIES
Silver

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Hi Christopher,

do you have the vlan 5 created on the 2950?

Have a "sh vlan". In the list the VLAN ID 5 should appear. If not your VLAN database lacks the vlan 5.

I assume Vlan 1 runs without any problem?

Best regards,

Frank

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Hi Frank,

Yes I have vlan 5 on the 2950, the sh vlan command verifies that. You are correct with saying that vlan 1 runs without any problems.

Silver

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Hi Christopher,

do you have the following also setup on the AP connected switchports:

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,5

Best regards,

Frank

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Yes I do.

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Well I take that back. I do not have switchport trunk encapsulation dot1q. That command does seem to exist with this 2950. I will try and upgrade the ios and see what happens.

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Well I upgraded the IOS on the 2950 but I still cannot use that command, switchport trunk encapsulation dot1q...

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

I am trying pretty much the same thing. My 2950 keeps giving this message.

2960-tech-admin-50.2#

01:32:17: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/20 on VLAN0

098. Port consistency restored.

01:32:17: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/20 on VLAN0

050. Port consistency restored.

01:32:18: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan i

d 98 on FastEthernet0/20 VLAN50.

01:32:18: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/20 on VLAN0098. In

consistent peer vlan.

01:32:18: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/20 on VLAN0050. I

nconsistent local vlan.

Although my config -very similar to yours- looks good.

Can you check to see if you are getting the same message in your switch?

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Yea, I am getting same error message on my 2950s

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Interesting - good to see I'm not the only one struggling.

Everything I have read says we are doing it correctly. I will attempt to run some debugs on the AP and switch.

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

I got mine working.

In the switch I issued the command

no spanning-tree vlan 50,98

Give it a try and let me know.

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

So you have your aps configured just like mine and on the 2950 switch, the port that you have the ap connected to, you have switchport mode trunk and then you issued the above command no spanning-tree on the appropriate vlans and now your able to pass traffic across your vlans over the wireless bridge? Is the above info, correct?

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Pretty much. First I tryed enabling spanning tree everywhere - since the error message was a STP message. After a few iterations of the config, it ended up like this in the 2950.

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

no spanning-tree vlan 50,98

and I can now pass traffic - all error messages are gone.

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Thanks, I'll give it a try later this afternoon and post my results.

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

The config on the port connected to the AP/Bridge should be:

int fa0/x

switchport trunk allowed vlan 1,5

switchport mode trunk

It looks like the VLANS are configured for the SSIDs. Make sure that the switch is a member of the VTP domain (I'm guessing that it is acting in a client role; 'sh vtp stat').

On the connected switch issue the 'sh interface fa0/x trunk' to see the trunked vlans on the switchport. Also, the 'sh spanning-tree summary' will show vlans on the switch. If the vlan is not listed, check that spanning-tree is working for the vlan. If it isn't, issue the command 'spanning-tree vlan x', where x is the desired vlan. On the bridge 'sh vlan dot1q' will show vlan traffic.

Hope this helps. Please remember to rate helpful posts, thanks.

T

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

It was the command

no spanning-tree vlan 50,98

that fixed my config.

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Well, this still did not work for me. Still having trouble with traffic crossing the bridges on all vlans except the native vlan.

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

As a side note specific to this thread in the post. 2950's only support 802.1q trunking so when you enable the trunk on the switchport with 'switchport mode trunk', the trunk encapsulation automatically gets set to 1q.

New Member

Re: Cannot get VLANs across wireless bridge. Need Help Please!

Yea I did read after posting the reply. I blew away the configs on everything for about the 10th time, reconfigured everything and it started to function properly. I do not know what was going on with the configs that I had. But it all works now. I really appreciate everybody's input on this.

344
Views
0
Helpful
18
Replies