Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

Cellular dialer hang-up issue


I am using a Cisco 881G router with cellular card PCEX-3G-CDMA-V.
The correct version of software is running according to the Cisco product overview documents: flash:c880data-universalk9-mz.124-22.T2.bin

While I am using the cellular connection surfing the Internet, watching videos, etc, the cellular link drops unexpectedly. The dialer idle-timeout is configured to 300 and while using the connection I am not idle. I am sending and receiving data. Although it reconnects automatically, the fact that it just drops carrier leaves me to believe I have something configured incorrectly.

My single strength is solid green to very fast blinking RSSI, which means single strength is excellent.

Any help would be greatly appreciated?
Tks
Frank

UPDATE: - If I set the dialer idle-timeout to 0, the dialer never times out and is active continuously. To shut down the cellular service, I shutdown the cell0 interface but this is not feasible for the actual user. Seems the "interesting traffic" ACL  isn't working.

Here are the related config settings
!
chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT"
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
load-interval 30
dialer in-band
dialer idle-timeout 300
dialer fast-idle 60
dialer wait-for-line-protocol 600
dialer wait-for-carrier-time 600
dialer string cdma
dialer-group 1
async mode interactive
no peer default ip address
fair-queue
ppp ipcp dns request
!
interface Vlan1
ip address 172.21.102.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 Cellular0
!
ip nat inside source route-map nat-cell interface Cellular0 overload
!
access-list 1 permit 172.21.102.0 0.0.0.255
dialer-list 1 protocol ip list 1
!
route-map nat-cell permit 10
match ip address 1
match interface Cellular0
!
line 3
exec-timeout 0 0
script dialer cdma
login
modem InOut
no exec
rxspeed 3100000
txspeed 1800000
! --snip--

2 REPLIES
Community Member

Re: Cellular dialer hang-up issue

Frank, I am working on this same router setup. Would you be willing to share

a clean configuration with me. I have been very unsuccessful in making the connection with the Internet

. Our goal is to enable this router for a back up solution when our m

ain connection fails.

Thanks,

Dave

Community Member

Cellular dialer hang-up issue

Frank,

I suggest turning on some debugs (debug dialer events, debug dialer packets, debug dialer maps) and watch the activity that takes place around the dialer events that are causing your link to time out.

The 'show dialer' command will show you the status of the timers, and you will see if the timeout is being reset when interesting packets are detected.

RB

925
Views
0
Helpful
2
Replies
CreatePlease to create content