Cisco Support Community
Community Member

Cisco 887vaw stuck in ap:

When i login in the service-module wlan ap 0 session i get a ap:

I would like to know how i can get out of this mode for the wireless ap tp function.




Oops!that is "ap mode" pretty


that is "ap mode" pretty much the same as "rommon mode" of router or "switch mode"

your OS may be corrupt


>dir flash:


See if you still have an image installed

>boot     -to load if any

If not, well you need to do image recovery of course :)

Community Member

Hi,When i do a dir flash: i


When i do a dir flash: i don't see any image.

Sorry for my little understanding,can you explain to me how i can do an image recovery?



Well 1st thing's first you

Well 1st thing's first you need to get an image 

Once you get it:   

Here are the steps, there are two ways, but ill show your the one i use often:

Oh yeah, setup TFTP never forget :D

1. Turn OFF AP and set-up console/CLI
2. Power ON AP and enter break sequence 
   **If 'ESC' break sequence does not work
     1. Turn OFF AP
     2. Hold MODE
     3. Turn ON
           -Let the MODE Firmware recovery process
           fail - you will now be in AP mode
3. At ROMMON Prompt, Initiate Commands:
>set IP_ADDR
>set             -Verify Settings
>ether_init            -Enable Ethernet
>tftp_init                -Enable TFTP
>tar -xtract tftp:// flash:
4. Reload: >boot
Community Member

Hi,When i do a ether_init i


When i do a ether_init i get this error Can not acquire Tx/Tx SYN maccfg1 is 0x35 and i guess this prevents me to upload the firmware.

Is there anyother way i can upload the firmware?






Yeap there is, using the MODE

Yeap there is, using the MODE button:

1. Turn OFF AP
2. Set-up TFTP on PC/Laptop to AP
-Configure PC to have an IP Address -   -choose an IP
3. RENAME Image File
FROM: c1140-k9w7-tar.124-25d.JA1.tar
TO: c1140-k9w7-tar.default
->Make sure you change the EXTENSION  of the file
4. Turn OFF AP
    A. Setup CLI & Ethernet
-Hold for 20-30 seconds
-LED will turn steady RED
-CLI will display TFTP download  initialization
Again, make sure you have renamed the file and its EXTENSION.
Community Member

Hi,This is a built-in AP on a


This is a built-in AP on a Cisco 887vaw.

Where do i turn off the AP802 on the 887vaw router?

I guess your settings are for a normal access point.

Thanks and sorry for my little understanding of cisco wireless!





Hi hypen,The configuration is

Hi hypen,

The configuration is pretty much the same,
Since that is an 8xx series, probably the whole IOS has gone haywire

Recover it using the normal process in a router


its pretty much the same as an AP, it still has a dot11radio interface
Oh yeah, with regards to your device you might need to enter

service-module wlan-ap0 session


It's a command that lets you enter the ap configuration (w/c) is in autonomous
Again, you need to configure an IP

Better yet check this configuration guide :)

And a full pdf guide:


Okay okay, I was visualizing

Okay okay, I was visualizing your problem annd poof it came to me

once you entered: service-module wlan-ap 0 session

you went to ap right?
is it ap> or ap:

If its ap> then that is it!
You can start configuring your WLAN device


If you want the UI, check the ip of the BVI interface, it is automatically routed by the router
once you are in the ap> section 

do; show ip int br
to see IP of the BVI

access the UI, with default creds: Cisco and Cisco as password

Then configure wireless, 
If im corrent that supports MBSSID but for now configure just one
You can do it by GUI, but I usually do it through CLI:

dot11  ssid MY_WIFI     -your ssid

authentication open

authentication key-management wpa version 2

wpa-psk ascii p@ssw0rd



interface dot11radio 0  

encryption mode ciphers aes

ssid MY_WIFI

no shutdown




I would highly recommend

I would highly recommend reading the links I gave you and the PDF for everthing you need to know and further question sperhaps are there, neatly arranged :)

Community Member

Hi,It's in ap: mode and not


It's in ap: mode and not ap>

How do i turn of the ap and where is this hold mode button?

I will have a look at the links you sent.

Many thanks!



That's weirdThe hold button i

That's weird
The hold button i am talking about exist in the AP only.
Have you tried reloading the IOS of the 800 series router?
Im pretty sure that it is bundled, basically one IOS for the router and AP

Can you try a firmware refresh and load a new IOS and boot that one. See if it works.

See this link in recovering 800 series routers;

Community Member

Hi,I have already loaded a


I have already loaded a new ios on the router side and still when i login the ap

i always get ap:

Trying all the commands to load an ios via tftp fails.

What does not work is the commad ether_init which does not bind the router interface ethernet 0 to the ap bvi interface.

The ap has it's own ios and i think this time Cisco to me has done a messy way of recovering a corrupt  imbedded ap.

The best thing should have been to load an ap ios from the router flash but i don't think that's possible.

Thanks again!



Have you tried accessing the

Have you tried accessing the configuration terminal once you are in ap?

conf t
If that works, then you can configure your AP
the ether_init initializes TFTP Transfer

Based on what I know, the APs image is embedded on the router, this typically it has two IOS

See this link as well as basis:

It's the 2nd question

So pretty much you need an 800 series AP image.
Then if it is really ap:, then you are really in ap: mode, the AP image is lost (w/c is weird considering the router's image is fine)


Can you try recovering it again?
once you are in ap: mode, type in >set

to see the default values and give you an idea on what values you must set for TFTP to work

Also, please make sure you are directly connected to the device
try recovering using different ports

To add, please make sure you have a TFTP server software such as tftpd32 software.

CreatePlease to create content