Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

cisco aironet 1310G non_native vlan and dhcp

hi evrybody

i have problem with my cisco aironet 1310G

non-native vlan can not get(dynamicly)ip address from cisco aironet 1310G

this is all my configuration please can someone help me

ip dhcp excluded-address 20.20.20.20

ip dhcp excluded-address 20.0.0.0

ip dhcp excluded-address 30.0.0.0

ip dhcp excluded-address 30.30.30.30

ip dhcp excluded-address 10.0.0.0

ip dhcp excluded-address 10.0.0.10

ip dhcp excluded-address 10.1.0.0

ip dhcp excluded-address 10.1.0.10

!

ip dhcp pool d01

network 10.0.0.0 255.255.255.0

default-router 10.0.0.10

!

ip dhcp pool d02

network 20.0.0.0 255.255.255.0

default-router 20.20.20.20

!

ip dhcp pool d03

network 30.0.0.0 255.255.255.0

default-router 30.30.30.30

!

!

no aaa new-model

!

dot11 ssid vlan01

vlan 1

authentication open

dot11 ssid vlan02

vlan 2

authentication open

!

dot11 ssid vlan3

vlan 3

authentication open

!

username cisco password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

broadcast-key vlan 2 change 100

!

broadcast-key vlan 3 change 100

!

ssid vlan01

!

ssid vlan02

!

ssid vlan3

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root access-point

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

!

interface Dot11Radio0.3

encapsulation dot1Q 3

no ip route-cache

bridge-group 3

bridge-group 3 subscriber-loop-control

bridge-group 3 block-unknown-source

no bridge-group 3 source-learning

no bridge-group 3 unicast-flooding

bridge-group 3 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

hold-queue 80 in

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface FastEthernet0.3

encapsulation dot1Q 3

no ip route-cache

bridge-group 3

no bridge-group 3 source-learning

bridge-group 3 spanning-disabled

!

interface BVI1

ip address 10.0.0.10 255.255.255.0

no ip route-cache

!

interface BVI2

ip address 20.20.20.20 255.255.255.0

no ip route-cache

!

interface BVI3

ip address 30.30.30.30 255.255.255.0

no ip route-cache

!

control-plane

!

bridge 1 priority 9000

bridge 1 protocol ieee

bridge 1 route ip

bridge 2 priority 10000

bridge 2 protocol ieee

bridge 3 priority 3100

bridge 3 protocol ieee

!

!

!

line con 0

line vty 0 4

login local

!

end

2 REPLIES
Community Member

Re: cisco aironet 1310G non_native vlan and dhcp

Greetings,

It would appear that your DHCP scopes are wrong.

When the dhcp request comes in it wont find a DCHP pool because BVI2 and BVI3 do not match your scopes. The network statement doesn't match. From my guess of what you meant to specify you should have the scopes to the following:

ip dhcp pool d02

network 20.20.20.0 255.255.255.0

default-router 20.20.20.20

!

ip dhcp pool d03

network 30.30.30.0 255.255.255.0

default-router 30.30.30.30

These two network statements would match both your BVI's.

To verify that your the requests are not finding a DHCP scope you could use this command on the ap... 'debug ip dhcp server {events | packets | linkage}'

Community Member

Re: cisco aironet 1310G non_native vlan and dhcp

hi friend

i did what you sugested but it is styl not working so plz find below the show run and debug ip dhcp server in ordr to help us thanks for all your suport

ip subnet-zero

ip dhcp excluded-address 20.0.0.20

ip dhcp excluded-address 30.0.0.30

ip dhcp excluded-address 10.0.0.10

!

ip dhcp pool d01

network 10.0.0.0 255.255.255.0

default-router 10.0.0.10

!

ip dhcp pool d02

network 20.0.0.0 255.255.255.0

default-router 20.0.0.20

!

ip dhcp pool d03

network 30.0.0.0 255.255.255.0

default-router 30.0.0.30

aaa new-model

!

dot11 ssid vlan01

vlan 1

authentication open

guest-mode

!

dot11 ssid vlan02

vlan 2

authentication open

!

dot11 ssid vlan03

vlan 3

authentication open

!

bridge irb

interface Dot11Radio0

no ip address

no ip route-cache

!

broadcast-key vlan 2 change 100

!

broadcast-key vlan 3 change 100

!

ssid vlan01

!

ssid vlan02

!

ssid vlan03

!

station-role root access-point

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

!

interface Dot11Radio0.3

encapsulation dot1Q 3

no ip route-cache

bridge-group 3

bridge-group 3 subscriber-loop-control

bridge-group 3 block-unknown-source

no bridge-group 3 source-learning

no bridge-group 3 unicast-flooding

bridge-group 3 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

hold-queue 80 in

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface FastEthernet0.3

encapsulation dot1Q 3

no ip route-cache

bridge-group 3

no bridge-group 3 source-learning

bridge-group 3 spanning-disabled

!

interface BVI1

ip address 10.0.0.10 255.255.255.0

no ip route-cache

!

interface BVI2

ip address 20.0.0.20 255.255.255.0

no ip route-cache

!

interface BVI3

ip address 30.0.0.30 255.255.255.0

ip helper-address 30.0.0.0

no ip route-cache

and debug ip dhcp server {events | packets | linkage}

*Mar 1 01:06:37.054: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating

Station 0011.a304.2b65 Reason: Sending station has left the BSS

*Mar 1 01:06:40.140: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 0011.a304

.2b65 Associated KEY_MGMT[NONE]

531
Views
0
Helpful
2
Replies
CreatePlease to create content