Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Configuring DHCP Server on a 1130AG?

Can it be done? I found the article, i followed it but still cant get it to work. I did some other research on the web, some people say it cant be done, where as the cisco documentation says it can be.

http://www.cisco.com/en/US/docs/wireless/access_point/12.3_8_JA/configuration/guide/s38adm.html#wpmkr1090318

I can see the AP, but the client will not get a IP from the AP. here is my config.

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname xxx

!

enable secret xxx

!

no aaa new-model

clock timezone -0500 -5

clock summer-time -0400 recurring

ip domain name xxx

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.201.1 192.168.201.20

!

ip dhcp pool Home

network 192.168.201.0 255.255.255.0

default-router 192.168.201.1

lease 10

!

!

ip dhcp-server 192.168.201.1

!

dot11 ssid hidden

authentication open

authentication key-management wpa

wpa-psk ascii xxx

!

dot11 ssid hiddena

authentication open

authentication key-management wpa

wpa-psk ascii xxx

!

power inline negotiation prestandard source

!

!

username Cisco password xxx

username spmadmin privilege 15 password xxx

!

bridge irb

!

!

interface Dot11Radio0

ip address 192.168.201.1 255.255.255.0

no ip route-cache

!

encryption mode ciphers tkip

!

ssid hidden

!

speed basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid hiddena

!

dfs band 3 block

speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

channel dfs

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

ip address x.x.x.x 255.255.255.248

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address x.x.x.x 255.255.255.248

no ip route-cache

!

ip default-gateway x.x.x.x

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

snmp-server community xxxx RO

bridge 1 route ip

!

!

banner motd

Unauthorized access is prohibited. If this was accidental, please disconnect immediately.

!

line con 0

line vty 0 4

login local

!

sntp broadcast client

end

Any help would be greatly appreciated.

Thanks in advance.

Ed

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Configuring DHCP Server on a 1130AG?

No problem. There are some Cisco products like the 871W that is router and wireless access point, but it also comes with a price more than what you can get for a Linksys or other SOHO vendors.

-Scott
*** Please rate helpful posts ***
5 REPLIES
Hall of Fame Super Silver

Re: Configuring DHCP Server on a 1130AG?

Your subnet mask doesn't match.. the clients will be put on the same subnet as the ap is on. Change it to 255.255.255.0 on the BVI interface.

Here is an example:

ip dhcp excluded-address 192.168.201.200 192.168.201.254

!

ip dhcp pool DHCP

network 192.168.201.0 255.255.255.0

lease 0 0 10

!

!

!

dot11 ssid surveya

authentication open

!

dot11 ssid surveyg

authentication open

guest-mode

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid surveyg

!

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

ssid surveya

!

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.201.254 255.255.255.0

no ip route-cache

-Scott
*** Please rate helpful posts ***
Community Member

Re: Configuring DHCP Server on a 1130AG?

what if my bv1 interface has a public IP?

basically I am setting up a public AP, with just basic WPA and WPA2 passkeys. I have this connected to business cable line, but the business cable only has 5 usable IPs.

I set the bv1 to a private ip with the subnet, but i can no longer access it remotely or connect to the internet from within the AP.

Hall of Fame Super Silver

Re: Configuring DHCP Server on a 1130AG?

You need a router to be able to NAT users. What is your setup anyways... You might need to get a router with wireless or maybe just a Linksys router or something like that.

-Scott
*** Please rate helpful posts ***
Community Member

Re: Configuring DHCP Server on a 1130AG?

Thanks. You just confirmed what i thought, I will probably just get a linksys router and let that handle the DHCP and NAT, it would make the config much more simpler.

in my crazy mind, i thought the wireless could do NAT and DHCP, it would have been nice, but maybe i should have done more research.

Hall of Fame Super Silver

Re: Configuring DHCP Server on a 1130AG?

No problem. There are some Cisco products like the 871W that is router and wireless access point, but it also comes with a price more than what you can get for a Linksys or other SOHO vendors.

-Scott
*** Please rate helpful posts ***
2290
Views
0
Helpful
5
Replies
CreatePlease to create content