Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DHCP Address Not Being Assigned - Only to certain clients

Another weird one popped up the other day....

We were replacing 7 autonomous 1231 AP's with 7 3600i's.  Once we replaced them, the AP's were up and running.  Users were connecting to them with no issue.  We started receiving reports that all of our handheld scanners were no longer working.  Within the WLC, you can see the clients.  However, they're not being assigned a DHCP address.  DHCP is being handled by an InfoBlox DHCP appliance.  Authentication occurs through our ACS.  You see a successful authentication, through the ACS.  Again, for some reason these devices do not receive a DHCP address, even though all other users have no issue.  I'm going down the path that we might've run into some compatibility issue with the handheld scanners and the new AP's.  Any thoughts?  Thanks!

Everyone's tags (4)
6 REPLIES
VIP Purple

DHCP Address Not Being Assigned - Only to certain clients

Post "debug client " output of your WLC while you are trying to connect sanner device to this SSID

That should help us to tell what's the problem

HTH

Rasika

Hall of Fame Super Silver

Re: DHCP Address Not Being Assigned - Only to certain clients

When you replace your autonomous to lightweight, did you remove the trunk port from the AP's and set them up as access ports? Do you have the interfaces defined properly on the WLC? Are you doing FlexConnect or local mode? Moving from autonomous to lightweight does require changes int he network.

Sent from Cisco Technical Support iPad App

-Scott
*** Please rate helpful posts ***
New Member

DHCP Address Not Being Assigned - Only to certain clients

Scott, thanks for the reply.  The new 3600's do not have their interfaces trunked, and are in FlexConnect mode.  Looking at the autonomous AP's, they didn't have their interfaces trunked either.  All switchports are access ports.  It's just really odd how all other entities such as laptops, ipads, iphones, droids, etc can connect with no issue, and these Psion RF scanners cannot. 

Rasika, thanks for your reply as well.  For the time being, we've shut off the wireless radios, on the new 3600's, and are running off of the old 1231 until we can get this figured out.  We're waiting for a time where we could test the RF scanners again, during end of business or on a weekend.  At that time, we'll put debug parameters on the MAC addresses. 

Again, thanks to both of you for your replies!

Hall of Fame Super Silver

DHCP Address Not Being Assigned - Only to certain clients

The new 3600's do not have their interfaces trunked, and are in FlexConnect mode.  Looking at the autonomous AP's, they didn't have their interfaces trunked either.  All switchports are access ports.  It's just really odd how all other entities such as laptops, ipads, iphones, droids, etc can connect with no issue, and these Psion RF scanners cannot.

If your AP's are in flexconnect mode and if you have the WLAN in local switching, then all the SSID's will be mapped to the subnet that the AP is on.  If the AP's are local to the site where the WLC is, then your AP's should not be in FlexConnect mode but should be in local mode. 

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
New Member

DHCP Address Not Being Assigned - Only to certain clients

Scott,

The WLAN is in FlexConnect local switching mode.  The controller, is not local to this site.  The AP's are in FlexConnect mode.  Thanks!


Steve

Hall of Fame Super Silver

Re: DHCP Address Not Being Assigned - Only to certain clients

Well then you need to debug the client Mac and see what the issue is. If other devices are getting an IP address using that same ssid, then it's most likely an issue with the scanner.

You can post the show WLAN

iPhones and iPads are the devices that seem to be the most problematic with certain configurations on the WLAN. So those devices being able to access the same ssid with no problem almost eliminates configuration issues on the WLAN. Have you talked to the support team for the scanners?

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
394
Views
0
Helpful
6
Replies
CreatePlease to create content