Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

dhcp issue

Hello mates!

I've got a strange issue that I haven't encountered before. What's happening is a particular ssid allows an association, but will not provide a dhcp address. Now, I have another ssid on the same controller, pointing to the same dhcp server, but different scope and it pulls dhcp fine for the clients. The ssids are in two differnt vlans. Both vlan interfaces contain an ip helper address. Both interfaces on the WLC contain a dhcp server address as well. Under the ssid's, advanced tab, they have the option for dhcp assignment required checked. So both setups look exactly the same. I can ping the dhcp server from the vlan with the ssid in question, so reachability isn't the issue. I've tried disabling the dhcp proxy feature on the WLC, but no go. The only difference that I can find is at the switch level. Keep in mind this is a wism. The ssid that I'm having the trouble with is on vlan 78, and on the switch it is set for the native vlan connecting back to the wism for the internal gig interfaces. shewww...any idea?

6 REPLIES
Hall of Fame Super Gold

Re: dhcp issue

If you plug a wired host/client into a switch and configure to the same VLAN, do you still get an invalid IP Address?

On the configuration for the 6500 chassis and the WiSM, do you have the VLAN's enabled and allowed?

Are you using H-REAP?

New Member

Re: dhcp issue

I'm not using HREAP.

Yes, I can plug a wired client in and get an ip.

The vlans are enabled and allowed.

Hall of Fame Super Silver

Re: dhcp issue

Your management and ap managers should be set on the wlc's as vlan "0" and what ever vlan they are on should be the one set to native vlan. It is best practice. All your dynamic interfaces should be tagged and you also should verify that you are allowing all your vlans on your etherchannel.

-Scott
*** Please rate helpful posts ***
New Member

Re: dhcp issue

This all checks out.

I've set it as you have described.

Silver

Re: dhcp issue

What type of security are you using? If you're using WEP, and you have the wrong key configured, clients will be unable to DHCP.

New Member

Re: dhcp issue

I found the fix.

What I had to do was go in and toggle the security under Layer2. Strange, but I switched it from static wep to wpa2 then back. That corrected the issue.

150
Views
0
Helpful
6
Replies