Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP on Air1230B on guest VLAN

Hi everybody,

I need to solve specific problem. I'm trying to create two SSIDs on my AP. The first for corporate users(encrypted) and the second FreeAccess.

All IP addresses and information are not final - it's LAB so far.

SSID

1.CorporateWLAN - encrypted, full access

2.FreeAccess - w/o encryption, guest-mode, only browsing(filters not included in following current-config)

I want to achieve assignement of IP adresses to wireless clients from AP(DHCP server on AP) but only to guestVLAN(VLAN ID 2) users.

BTW VLAN1 is native VLAN.

Interface's addresses are excluded from DHCP pool.

I'm not a pro in this area so all comments will be appreciated.

BTW again :), this config doesn't work.

CONFIG:

AP_TEST#sh run

*Mar 1 01:36:44.699: %SYS-5-CONFIG_I: Configured from console by console

Building configuration...

Current configuration : 2096 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname AP_TEST

!

logging queue-limit 100

enable secret xxx

!

username xxx password xxxx

ip subnet-zero

ip dhcp excluded-address 10.5.5.1 10.5.5.5

ip dhcp excluded-address 192.168.1.215 192.168.1.220

ip dhcp excluded-address 192.168.1.1 192.168.1.5

!

ip dhcp pool DHCPVLAN2

network 10.5.5.0 255.255.255.0

default-router 192.168.1.1

domain-name LAB

dns-server 10.5.5.3

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 1 key 1 size 128bit xxxxx

transmit-key

encryption vlan 1 mode wep mandatory

!

ssid CorporateWLAN

vlan 1

authentication open

!

ssid FreeAccess

vlan 2

authentication open

guest-mode

!

speed basic-1.0 basic-2.0 basic-5.5 basic-11.0

rts threshold 2312

channel 2462

station-role root

no cdp enable

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

bridge-group 2 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface BVI1

ip address 192.168.1.220 255.255.255.0

no ip route-cache

!

interface BVI2

ip address 10.5.5.1 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.1

ip http server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/122-15.JA/1100

ip radius source-interface BVI1

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

line vty 5 15

login

!

end

  • Other Wireless - Mobility Subjects
3 REPLIES
New Member

Re: DHCP on Air1230B on guest VLAN

1. RTFM :)

2. create SSID then assign it to dot11 X interface i.e. something like that:

ssid CorporateWLAN

vlan 1

authentication open

!

ssid FreeAccess

vlan 2

authentication open

guest-mode

!

interface Dot11Radio0.1

ssid CorporateWLAN

!

interface Dot11Radio0.2

ssid FreeAccess

your config dosen't work because you create 2 SSID on one interface, IMHO

3. RTFM again :)

http://www.cisco.com/univercd/cc/td/doc/product/wireless/airo1200/accsspts/b1237ja/i1237sc/s37scg.pdf

http://www.cisco.com/univercd/cc/td/doc/product/wireless/airo1100/accsspts/i1237ja/cr1237ja/cr37_p.pdf

helps you

New Member

Re: DHCP on Air1230B on guest VLAN

Good opinion - but SORRY doesn't work ;o)

As you stated, read the following material, more exactly pictures sol01.jpg and sol02.jpg.

Association of SSID's to radio sub-if is impossible in my version of IOS. As you can see on theese pictures there are 2 ways of configuring multiple SSIDs.

1. Interface-level configuration 12.2-prior

2. Global-level configuration - IOS 12.3 and higher

In my "shrun" as you has seen are SSID's configured properly(I think :) after reading materials from your links)- by interface-level style.

Screenshot scr01.jpg claims imposibility of sub-if SSID configuration.

BTW, thanks a lot for your time.

But it seems, that I am at the end of my knowledge about wireless configuration - and problem isn't solved :-(

Silver

Re: DHCP on Air1230B on guest VLAN

Try using:

"default-router 10.5.5.1", i.e., ip address from the default router of this subnet, under "ip dhcp pool DHCPVLAN2" configuration.

Hope this helps

190
Views
0
Helpful
3
Replies
This widget could not be displayed.