Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP Server in the Aironet 1520

Hi Everyone,

I have a 1250 AP connected to an Switch Cisco 3750. We have a SSID(vlan 1 - native) which get an IP Adress from our DHCP Server(located in a Windows 2003 server).

I added a new SSID in VLAN 2 and I would like no to use the DHCP Server but to make the AP get an IP Address from the pool I created in the own AP (ip dhcp pool Guest) but everytime I try to connect the new vlan, it doesnt get an ip address.

Follow the settings of the AP. Any help, it would be very appreciate.

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BETA

!

enable secret 5 $1$65KK$cvnK849DOoWzq8QiMA9On.

!

no aaa new-model

no ip dhcp use vrf connected

ip dhcp excluded-address 10.150.4.1

!

ip dhcp pool Guest

network 10.150.4.0 255.255.255.0

default-router 10.150.1.1

dns-server 10.150.1.48

domain-name xxx

!

!

!

dot11 ssid GUEST

vlan 2

authentication open

mbssid guest-mode

!

dot11 ssid INTERNAL

vlan 1

authentication open

mbssid guest-mode

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 1 key 1 size 128bit 7 BD4BDA5C243413C59A1115891509 transmit-key

encryption vlan 1 mode wep mandatory

!

encryption vlan 2 key 1 size 128bit 7 BD4BDA5C243413C59A1115891509 transmit-key

encryption vlan 2 mode wep mandatory

!

ssid GUEST

!

ssid INTERNAL

!

mbssid

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

!

encryption key 1 size 128bit 7 FC38FBE1CFEC896823254FB402C4 transmit-key

encryption mode wep mandatory

antenna gain 4

no dfs band block

channel width 40-below

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface BVI1

ip address 10.150.1.122 255.255.0.0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

snmp-server community Public RO

bridge 1 route ip

1 ACCEPTED SOLUTION

Accepted Solutions

DHCP Server in the Aironet 1520

go under the vlan 2 interface and do a no shut

also take a look at a show vlan brief and make sure that vlan 2 is there.  if it's not,

conf t

vlan 2

and that should build the vlan at L2

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
10 REPLIES

Re: DHCP Server in the Aironet 1520

Fernando,

To use the DHCP server on the ap, you'll need to point an ip helper address on the L3 interface, and point it at the IP of the AP. Otherwise the AP wouldn't know which scope to give the client.

Sent from Cisco Technical Support iPad App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

DHCP Server in the Aironet 1520

Stephen,

I set the gigabit ethernet 0.2 of my AP with ip helper-address 10.150.1.122 and the problem persists.

Have I made something wrong?

Thanks and sorry for the poor knowledgment techinical.

Fernando

DHCP Server in the Aironet 1520

  All the guest traffic is going to be bridged down into VLAN 2 by the AP, and doesn't require an IP address.  The ip helper needs to go on the L3 interface of the network, so where ever the routing is happening for VLAN 2.

HTH,

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

DHCP Server in the Aironet 1520

Stephen,

I have the following topology on my network:

Cisco AP <-------------> Switch 3750 <--------------------> Cisco Pix<------------------>Internet Router<------------> Internet

10.150.1.122               10.150.1.102                        10.150.1.1                    

                                  (enabled ip routing)    

Our default-gateway in the network is usually the 10.150.1.1. Should I use it?

Thank you very much.

Fernando

DHCP Server in the Aironet 1520

That wouldn't work, as it's not the same subnet as the guest, and looking at the guest scope, the default-router should be in the 10.150.4.0/24 subnet range.

So you would need an interface on either on the pix, or on the 3750 in VLAN 2.  This is where you would need to put the ip helper.

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

DHCP Server in the Aironet 1520

Stephen,

I changed the scope of my new range because it was overlapping with vlan 1 native. Well, I set the ip address of interface vlan 2 on my switch l3 3750 to 10.152.0.1 and set the ip helper-address to 10.150.1.122(ip address of the AP where is the DHCP pool). My laptop coulnt get the ip address.

Remenber I enabled "ip routing" on 3750 switch. Follow the config. The AP is connected in the Gi 1/0/16 port.

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname BR-SW-02

!

no aaa new-model

clock timezone UTC -3

switch 1 provision ws-c3750g-24t

system mtu routing 1500

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet1/0/16

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

!

interface Vlan1

ip address 10.150.1.102 255.255.0.0

!

interface Vlan2

ip address 10.152.0.1 255.255.0.0

ip helper-address 10.150.1.122

!

ip default-gateway 10.150.1.1

ip classless

ip http server

DHCP Server in the Aironet 1520

it wouldn't have, the scope you have defined on the AP is not the same scope as what you configured for VLAN 2.

ip dhcp pool Guest

network 10.150.4.0 255.255.255.0

default-router 10.150.1.1

dns-server 10.150.1.48

You would need to change the scope on the AP to match the address on VLAN 2 on the switch

so:

conf t

no ip dhcp pool Guest

network 10.152.0.0 /16

default-router 10.152.0.1

dns-server 10.150.1.48

!

exit

wr

and that should fix you up.

HTH,

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

DHCP Server in the Aironet 1520

Stephen,

Everything seems to be fine but even all, my new ssid still cant get the correct ip address. I noted the my interface vlan 2 on the switch 3750 is down. Is it correct?

BR-SW-02#sh interfaces vlan 2

Vlan2 is down, line protocol is down

  Hardware is EtherSVI, address is 68bd.ab34.1ec1 (bia 68bd.ab34

  Internet address is 10.152.0.1/16

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255 BR-SW-02#sh interfaces vlan 2
Vlan2 is down, line protocol is down
  Hardware is EtherSVI, address is 68bd.ab34.1ec1 (bia 68bd.ab34
  Internet address is 10.152.0.1/16
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255

I have no device connected in this vlan.

Thanks for your patience and support.

Fernando

DHCP Server in the Aironet 1520

go under the vlan 2 interface and do a no shut

also take a look at a show vlan brief and make sure that vlan 2 is there.  if it's not,

conf t

vlan 2

and that should build the vlan at L2

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

DHCP Server in the Aironet 1520

thank you very much for your support.

Now I am facing a new problem which is related in other post. If you could help me, I will be really thankful.

Thanks a lot.

Fernando

569
Views
0
Helpful
10
Replies