Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Duplicate IP on Cisco 5508 LAG and Nexus 2k

  Hi all,

I am having a problem that I cant seem to find anything wrong with. The setup is as following.

A 5508 with interface LAG. 2 of a total of 4 interfaces are connected to a Nexus 2k  that is connected to a 5k fabric and the other 2 5508 interface are connected to another set of 2k-5k nexus and the 5ks are also interconnected.

The issue is that the 5508 controller is complaining that it has decteted a duplicate IP being used by MAC H:H:H  which is in fact the MAC of it self. So basically it can see it self as another device via the LAG.

The setup is working and there is no problem reaching the controller in anyway. I dont know about parsing traffic or APs as this is a 3rd backup controller so I havnt anything to test with but when the controller was connected to a 6500 setup running VSS there was no problem so I was just wondering if any of you had run into a similar problem?

I know the most likely place to look is at the nexus but that setup is a by the book design and configuration and there are no logs that indicate anything on any device other than the WLC is reporting duplicate IP.

Everyone's tags (4)
6 REPLIES
VIP Purple

Re: Duplicate IP on Cisco 5508 LAG and Nexus 2k

You cannot configure LAG on 5508 unless all those ports are connect to single switch. In 6500 VSS even though it is two physicall chassis, logically it is a single switch.

But with your N5K, those won't be a single switch. So you will have this issue unless you connect all 4 ports onto single N5K/2K.

HTH

Rasika

**** Pls rate all useful responses ****

New Member

Re: Duplicate IP on Cisco 5508 LAG and Nexus 2k

There is configured a vPC between the 2 nexus 5k so they should appear as one switch to the controller.

New Member

You are correct.  But it

You are correct.  But it sounds like the Etherchannel on the Nexus is either not configured or not configured correctly.  Make sure the Etherchannel is configured Mode On, ie no LACP.   The WLC can be configured as 8 individual ports or a single 8 port Etherchannel.

I hope this helps.

John

New Member

Everything has been checked

Everything has been checked out and following best practice regarding LAG on WLC so thats where this issue has stranded.

New Member

Were you ever able to get

Were you ever able to get this issue resolved?  I am just wondering if this setup is supported at this time.  I am looking at connecting a WLC 5508 LAG via a VPC on 2 2K's that are Single homed to upstream 5548's.

 

Any updates are appreciated.

New Member

No I never got this solved

No I never got this solved and as this is a third wlc backup solution it has not gotten anymore attention how ever failover testing has shown the wireless to work fine.

330
Views
0
Helpful
6
Replies
CreatePlease login to create content