Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

enabling 802.11n on the 861-w ISR

Hello,

I'm attempting to configure 11n on the 861W router integrated access point. I've configured

speed basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m8. m9. m10. m11. m12. m13. m14. m15.

But still can't connect faster than 54Mb. Are there any comprehensive instructions for how this works?

Any help surely appreciated.

9 REPLIES
Hall of Fame Super Silver

Re: enabling 802.11n on the 861-w ISR

For 802.11N, you need to use only open authentication or wpa2-aes. Also, you need to bond the channels to 40mhz. Here is a link:

http://www.cisco.com/en/US/docs/routers/access/800/860-880-890/software/configuration/guide/radio_config.html#wp1053650

-Scott
*** Please rate helpful posts ***

Re: enabling 802.11n on the 861-w ISR

Ditto on open/wpa2aes, but I don't believe that channel bonding is a requirement for N. As long as the client adapter is N-draft ready with 2x2/2x3 spatial stream support, you can get theoretical 130-144Mbps / practical around 75Mbps throughput without channel bonding

Re: enabling 802.11n on the 861-w ISR

your client adapter might be 802.11abg only, are you sure it supports N?

Community Member

Re: enabling 802.11n on the 861-w ISR

Thanks for the comments.

Currently I have authentication open. For now I'm in the lab just trying to get anything greater than 54 Mb.

I don't see where enabling WMM is documented. I issued the command:

#dot11 qos mode wmm

but that did not make a visible change in the config.

I also don't find the CLI command to do the channel bonding or change the guard interval.

The #show associations all command always reports that the "Current rate" is 54.0. The scan facility on the client utility reports "Wireless mode: 2.4 GHz 130 Mbps." But the real time status indicator always reports "Current receive rate: 54.0 Mbps."

The client adapter is based on the Atheros AR5008E-3NG chipset and I'm positive that it is 802.11n capable, but check it out. This is strickly a 2.4 GHz 11n chipset. And, the adapter is a mini-PCI card in a laptop with only one antenna.

Question: do I need to have more than one antenna attached to realize speeds greater than 54 Mbps at 2.4 GHz?

Question: I read somewhere Cisco doesn't support channel bonding on 2.4 GHz. It this true even on the 861-W, or just true on stand only access points?

Re: enabling 802.11n on the 861-w ISR

I'm in no way a wireless expert, so please take my comments with a grain of salt.

Channel bonding is not supported on *some* of Cisco's 2.4 Ghz radio configuration options (861 is a 2.4Ghz only radio, your client is also 2.4Ghz only). Channel bonding is not recommended on 2.4Ghz, because of a small number of non-overlapping channels available in the 2.4Ghz band. Are you sure that "channel width" command is not available on your Dot11Radio0 interface? I can see it in the 861 IOS configuration guide. In any case, you don't need channel bonding to use 802.11n 144Mbps theoretical speed thanks two dual spatial streams (+ some other improvements of N).

144Mbps is a speed when client has 2x3 antennas (2 transmit x 3 receive). 130Mbps is a speed when client has 2x2 radio (2 transmit x 2 receive). I looked up AR5008E-3NG and they actually claim to have 3x3 radio (3 transmit x 3 receive). From what I hear those 3x3 radios don't actually transmit three spatial streams. They transmit two streams and use the 3rd antenna for additional output power. So 3x3 is actually 2x3. I don't believe there are any true 3x3 chipsets available.... yet. Maybe some day we'll see 4x4 (max allowed by 802.11n standard)

I believe that 144Mbps for 2x3 and 3x3 is only when you have 400-ns guard interval, but since you are probably at the default 800-ns guard interval, that must be why you see 130Mbps in the utility. I could be wrong on that, though. I still haven't grasped the entire math of 802.11n

Did you say you only have one antenna attached to the 861 router? Yes, you must have all three antennas attached. If you only have 1 or 2, you'll get pretty bad results.

If you have all three antennas attached to 861, and still can't associate at 130/144 speeds, then I'm pretty sure it's some setting in your client's adapter configuration that must be enabled.

Also, paste your IOS config here.

Community Member

Re: enabling 802.11n on the 861-w ISR

Thanks for your reply - much appreciated.

What I was trying to say was my test client only had one antenna, since it's an old Dell 8200 with an newer "n" card in it. But I was able to rig two more antennas (antenni?). I was also able to set "channel width 40-above" on the 861-W. Now, on the client utility I get receive rates poping up to 300 Mbps and transmit rates in the 108 to 168 range.

According to Table 2 on this page:

http://www.cisco.com/en/US/products/ps6366/products_tech_note09186a0080a3443f.shtml

that signifies a guard interval of 800ns on transmit, but 400ns on receive.

Is there a command to explicitly set the guard interval?

RRodichev, I am also wondering what leads you to believe that the 861-W is 2.4 GHz only? I don't see anything in the data sheet about frequency bands.

Finally, there is anyone who knows what all of the codes are in the

#show dot11 statistics client-traffic

command mean?

Here's the AP config:

Current configuration : 2270 bytes

!

! Last configuration change at 10:28:45 EDT Sun Apr 30 1905

! NVRAM config last updated at 13:15:04 EDT Tue May 5 2009

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$U4BR$hXHAUw3QwGBCNMYwAFD7B0

!

no aaa new-model

clock timezone EST -5

clock summer-time EDT recurring

!

!

!

dot11 ssid Public Assets

vlan 1

authentication open

!

dot11 ssid Voices for Vermont Children

vlan 2

authentication open

!

!

!

username Cisco password 7 05280F1C2243

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid

!

ssid

!

speed basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m8. m9. m10. m11. m12. m13. m14. m15.

channel width 40-above

station-role root access-point

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 protocol ieee

bridge 1 route ip

bridge 2 protocol ieee

!

!

!

line con 0

no activation-character

line vty 0 4

login local

!

end

Re: enabling 802.11n on the 861-w ISR

sorry for the delay

I'm curious what you mean by adding two more antennas to your client (definitely "antennas" for radios, "antennae" is for biology). Isn't that client an internal card? Or are you referring to some configuration setting?

ok, so you doubled your channel width and you got more than one antenna, so yes, that would get you up to 300mbps

The AP automatically supports 400ns guard interval. The default setting is "guard-interval any" on the interface. If you want to force it to support only the original 800ns, then you would set "guard-interval long". So in your case, you just have to make sure that your client has 400ns GI enabled.

400ns GI vs. 800ns GI gives you around additional 10% of throughput.

http://www.cisco.com/en/US/products/ps9555/index.html

861 is b/g/n only (2.4Ghz band), so there's no a/n support (no 5Ghz band)

If your client is a/b/g/n, you can only take advantage of b/g/n

Community Member

Re: enabling 802.11n on the 861-w ISR

Thanks.

It's an old laptop, so it only has one antenna. One can buy generic internal antennas on ebay for about $4 each, run the wires out of the mini-PCI opening and tape the antennas to the back of the LCD cover. It's not pretty though.

Do you have any insight the codes from

#show dot11 statistics client-traffic

?

Is this documented somewhere?

Re: enabling 802.11n on the 861-w ISR

i think this command is undocumented:

136-0023.6cf0.c340 pak in 63 bytes in 5785 pak out 25 bytes out 4387

dup 0 decrpyt err 0 mic mismatch 0 mic miss 0

tx retries 0 data retries 0 rts retries 0

signal strength 59 signal quality 38

136 is the association ID

0023.6cf0.c340 is the mac address of the client

the next three lines are some stats about sent/received packets and encryption stats

signal strength 59 = I think this is in -dBm

signal quality 38 = RSSI 38

961
Views
0
Helpful
9
Replies
CreatePlease to create content