Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Guest WLAN making other WLAN stop working

Hi,

I have a WLC 2500 WLC.  I have a WLAN for internal use which is working fine. This is using the management interface.  When I add a second WLAN for guest users on a dynamic interface (called guest) on VLAN 20, the internal WLAN stops functioning properly.  When I enable the guest WLAN, anyone trying to connect to the internal WLAN doesn't get an IP address.  I want the users on the guest WLAN to get an IP from a router connected to the guest network which will also provide internet access.

This is a summary of my setup:

Internal WLAN:

management interface, DHCP server on the network, no VLAN tagging, subnet 192.168.6.x

Guest WLAN:

dynamic interface, DHCP server on the guest network, VLAN 20, subnet 192.168.0.x

On the switches, I have set up the port connected to the WLAN as a trunk, while the port connected to the router for the guest network as static access on port 20.

Any ideas what may be the problem?

Tiziana

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: Guest WLAN making other WLAN stop working

HI Tiziana,

Dont use swicthport access vlan 20 command.

Use this config:

interface GigabitEthernet0/21

switchport trunk encapsulation dot1q

swicthport access vlan 20

switchport trunk native vlan 1-------

switchport trunk allowed vlan 1,20

switchport mode trunk

Try this and let me know the result

Regards

Dont forget to rate helpful posts

11 REPLIES
VIP Purple

Guest WLAN making other WLAN stop working

Hi,

Can you paste the config of the swicth port where wLC is connected??

Normally this should be the config:

interface f0/xx

Description Connected to the WLC

switchport trunk encapsulation dot1q

switchport trunk native vlan

switchport trunk allowed vlan ,20

switchport mode trunk

also check this docs:

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a008070ba8f.shtml

Regards

Dont forget to rate helpful posts

New Member

Guest WLAN making other WLAN stop working

Hi,

Thanks for the prompt reply.  I had seen the document before...what is strange is that I had done this configuration at two other sites with no problems.

Here is the config for the switch port where WLC is connected:

interface GigabitEthernet0/21

switchport access vlan 20

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,20

switchport mode trunk

This is copied from the running config.

Tiziana

VIP Purple

Re: Guest WLAN making other WLAN stop working

HI Tiziana,

Dont use swicthport access vlan 20 command.

Use this config:

interface GigabitEthernet0/21

switchport trunk encapsulation dot1q

swicthport access vlan 20

switchport trunk native vlan 1-------

switchport trunk allowed vlan 1,20

switchport mode trunk

Try this and let me know the result

Regards

Dont forget to rate helpful posts

New Member

Re: Guest WLAN making other WLAN stop working

HI Sandeep,

Yes, vlan 1 is my management VLAn.

I will try this tomorrow as I am currently offsite and will let you know.

Thank you,

Tiziana

New Member

Re: Guest WLAN making other WLAN stop working

One more question, what about the port connected to the router on guest network (this will only see traffic from the guest network).

Right now it is set up as:

interface GigabitEthernet0/20

switchport access vlan 20

switchport mode access

Is this correct?

Thanks,

Tiziana

VIP Purple

Re: Guest WLAN making other WLAN stop working

Can you please posts the topology disgramm then I can say about this above problem.

Regards

New Member

Re: Guest WLAN making other WLAN stop working

Hi Sandeep,

Attached is the diagram.  VLANs are configured on the core switch.

Tiziana

VIP Purple

Re: Guest WLAN making other WLAN stop working

Hi,

For the port where your router is connected :

interface GigabitEthernet0/20

switchport access vlan 20

switchport mode access

this is the right config, dont need to change anything.

just change the port config where WLC is connected.(As per my last posts)

Regards

Dont forget to rate helpful posts

New Member

Re: Guest WLAN making other WLAN stop working

Thanks Sandeep.

Will try tomorrow and update accordingly.

Tiziana

New Member

Re: Guest WLAN making other WLAN stop working

Hi,

When I changed the VLAN on the switch as per Sandpeep instructions, the problem of having either production or guest VLAN working was solved.

However, I still could not get IP addresses for the guest WLAN from the external router (192.160.0.1).  I had to go with a workaround and set the WLC as the DHCP server for the guest WLAN.  This solved the issue immediately and guests were placed on a seperate VLAN & subnet with guest internet access only.

Thanks for the help,

Tiziana

VIP Purple

Re: Guest WLAN making other WLAN stop working

Glad that my post work for you and thanks for rating.

Reagrd

Dont forget to rate helpful posts

302
Views
0
Helpful
11
Replies