Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Having problems installing aironet 1240ag - cisco 7920 and call manager

The situation is the following we are trying to install a cisco 7920 phone using an AP aironet 1240ag while connected to a switch that uses 2 vlans.

vlan 1 voice

vlan 2 data

When we plug the AP into the switch the DHCP server assigns a 192.168.10.XXX IP address which is the data vlan. We need to use the voice vlan1 in order to registered the 7920 with callmanager.

So we went into the ap and set the IP statically to 10.0.0.XXX (which is the voice vlan), 255.255.255.0 and still not able to appear in the switch still picking up the 192.168.10.XXX ip address. Which causes the cisco 7920 to pull 192.168.10.XXX.

We have tried to set the phone statiscally as well but is unable to reach call manager because the ap is unable to show in our system.

any help will be certanly appreciated thank you

4 REPLIES
Bronze

Re: Having problems installing aironet 1240ag - cisco 7920 and c

The switchport needs to be trunked to see both Vlans.

Please re-look at your sh int for that port.

New Member

Re: Having problems installing aironet 1240ag - cisco 7920 and c

I am not really an expert but how do i trunk port 9, the ap is connected to port 9 and this is the config

interface FastEthernet0/9

description VOICE & DATA

switchport mode access

switchport voice vlan 1

switchport priority extend cos 0

no ip address

mls qos trust device cisco-phone

mls qos trust cos

storm-control broadcast level 50.00

storm-control multicast level 75.00

storm-control unicast level 75.00

auto qos voip cisco-phone

wrr-queue bandwidth 20 1 80 0

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

!

thank you for your help

New Member

Re: Having problems installing aironet 1240ag - cisco 7920 and c

I try to set the 0/9 port to trunk and this is what i get

bnp_sw_1(config-if)#switchport mode trunk

Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "tru

nk" mode.

what can i do ?

New Member

Re: Having problems installing aironet 1240ag - cisco 7920 and c

alright i was able to trunk the port 0/9

!

interface FastEthernet0/9

description VOICE & DATA

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 1

switchport priority extend cos 0

no ip address

mls qos trust device cisco-phone

mls qos trust cos

storm-control broadcast level 50.00

storm-control multicast level 75.00

storm-control unicast level 75.00

auto qos voip cisco-phone

wrr-queue bandwidth 20 1 80 0

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

!

same issue? what i do next?

167
Views
0
Helpful
4
Replies