Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Help Configuring Cisco C887VA-W-E-K Wireless

Hi,

im having trouble to configure the wireless on the Cisco C887VA-W-E-K router.

I managed to get the DSL working using cable, but cant seem to connect to the router when i use Wireless. I can see the SSID and when i double click on it i get the Network Key promo. I input the network key, the router seems to try and connect me but then it fails, its as if the router cannot give me an IP address even though i have DHCP configured on the router. Maybe the AP and The router arent linked up?

I have configured many wireless devices in the past, but this new model is different, it seems Cisco have changed their router infrastructure and seperated the router from the AP.

From the router i can ping the AP IP address and i have the latest IOS - C800-Universal-mz.SPA.151-4.M4

Any help would be appreciated - thanks in advance.

Here is a copy of the config

ROUTER CONFIG:

Building configuration...

Current configuration : 3681 bytes

!

! Last configuration change at 14:11:43 UTC Mon Jun 18 2012

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Test-DSL

!

boot-start-marker

boot-end-marker

!

!

enable secret test

!

no aaa new-model

crypto pki token default removal timeout 0

!

ip source-route

ip cef

!

ip dhcp excluded-address 192.168.0.1 192.168.0.3

ip dhcp excluded-address 192.168.0.201 192.168.0.254

!

ip dhcp pool ccp-pool1

network 192.168.0.0 255.255.255.0

domain-name test

dns-server 8.8.8.8

default-router 192.168.0.1

!

ip name-server 8.8.8.8

no ipv6 cef

!

license udi pid C887VA-W-E-K9 sn FCZ1620C0VP

!

username test privilege 15 password 0 tes

!

controller VDSL 0

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface Ethernet0

no ip address

shutdown

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

no ip address

!

interface wlan-ap0

description Embedded Service module interface to manage the embedded AP

ip address 192.168.1.1 255.255.255.0

!

interface Vlan1

ip address 192.168.0.1 255.255.255.0

!

interface Dialer1

description Primary Interface - DSL

ip address negotiated

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname username@tes.net

ppp chap password 0 test

ppp ipcp dns request

no cdp enable

!

ip forward-protocol nd

ip http server

ip http authentication local

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

AP CONFIG:

Building configuration...

Current configuration : 1847 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Test-AP

!

logging rate-limit console 9

enable secret 5 $1$6.kH$9KA54FGNt5OM7r/BeEopB0

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid Test

   authentication open

   mbssid guest-mode

!

dot11 ssid Test-Aramark

   vlan 1

   authentication open

   authentication key-management wpa version 2

   guest-mode

   wpa-psk ascii 7 032F5205011C2C494F0D

!

!

!

username build privilege 15 password 7 06041A28404A

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 1 mode ciphers tkip

!

broadcast-key vlan 1 change 30

!

!

ssid Test

!

ssid Test-Aramark

!

antenna gain 0

speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0

basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 basic-m0. basic-m1. basic

-m2. basic-m3. basic-m4. basic-m5. basic-m6. basic-m7. basic-m8. basic-m9. basic

-m10. basic-m11. basic-m12. basic-m13. basic-m14. basic-m15.

station-role root bridge

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecti

ng AP with the host router

no ip address

no ip route-cache

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.0.3 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.0.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

snmp-server community wrtnwsn RW

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

1 ACCEPTED SOLUTION

Accepted Solutions

Help Configuring Cisco C887VA-W-E-K Wireless

Hi Rafik,

I think this will help you:

http://www.cisco.com/en/US/docs/routers/access/800/860-880-890/software/configuration/guide/wlan.html#wpxref58512

Amjad

Rating useful replies is more useful than saying "Thank you"
3 REPLIES

Help Configuring Cisco C887VA-W-E-K Wireless

Hi Rafik,

I think this will help you:

http://www.cisco.com/en/US/docs/routers/access/800/860-880-890/software/configuration/guide/wlan.html#wpxref58512

Amjad

Rating useful replies is more useful than saying "Thank you"
New Member

Help Configuring Cisco C887VA-W-E-K Wireless

Hi Amjad,

Thanks for your reply. I did look at this link before i posted on here.

I tried to follow the instructions from cisco as best i can but it still doesnt work.What am i missing from my config?

New Member

Help Configuring Cisco C887VA-W-E-K Wireless

I started from scratch again and this time its working. The only noticeable difference is the following on the router config

interface wlan-ap0

description Embedded Service module interface to manage the embedded AP

ip unnumbered Vlan1

i believe the "IP unnumbered" Vlan1 command is what link the router with the AP.

On the AP, there was a few things that changed, here is a copy:

Building configuration...

Current configuration : 1439 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Test-AP

!

logging rate-limit console 9

!

no aaa new-model

!

dot11 syslog

!

dot11 ssid Test-AP

   authentication open

   authentication key-management wpa version 2

   guest-mode

   wpa-psk ascii 0 Test

!

bridge irb

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers tkip

!

ssid Test-AP

!

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description  the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.0.2 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.0.1

ip http server

ip http authentication local

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!        

line con 0

line vty 0 4

login local

!

end

721
Views
0
Helpful
3
Replies
CreatePlease to create content