Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help required with WLC software upgrade

I have a customer with  WLC 4402 in use, running software version 7.0.98.0, and supporting 11 APs at present. The customer wants to enlarge the WLAN, which involves increasing the number of APs. I have purchased a new WLC5508, and have installed it onto the network alongside the 4402. the 5508 is running software version 7.0.116.0. Because the wireless network is critical to the user, we want to move the APs over to the new controller while the network is up and running, then remove the 4402.

However, when we set the 5508 as the master controller, or tell one of the APs to use the 5508 as its primary controller, the AP connects to the new controller, downloads the new software version, attempts to load it but reports an error with the unzipped file size of the software and fails to boot. formatting the flash on the AP, then disconnecting the 5508 from the network and rebooting the AP allows it to connect to the 4402, it downloads the older software and boots as normal. A new AP, if connected to the 5508 in a test scenario (ie no 4402) connects, downloads and boots perfectly.

I have the upgrade software to allow the 4402 to be upgraded to 7.0.116.0, but I am concerned that, if this is installed, the existing APs will then fail to boot from the 4402 or the 5508.

all APs are 3502s, running IOS version 12.04(23c)JA when connected to the 4402 and 12.04(23c)JA2 on the 5508.

Any suggestions would be gratefully received

Thanks

7 REPLIES
Hall of Fame Super Silver

Help required with WLC software upgrade

I wouldn't use master controller mode in your case, just because it might disrupt your other AP's.  Did you setup the mobility betwen the two WLC's and the mobility is up?  You can also, download 7.0.116.0 to the 4402 and set that as the backup image.  Then you can pre-download the backup image to the AP's and then move one AP to the 5508 to see if that works.

-Scott
*** Please rate helpful posts ***
Cisco Employee

Help required with WLC software upgrade

Hi Rob,

Do you happen to have the console output of an AP when this upgrade failure occurs? If so, please attach it here for review.

It sounds like the AP image bundle might be corrupt on the WLC, in which case you can either re-load 7.0.116.0 code on it, or load the newly released 7.0.220.0 code to refresh the AP images.

-Pat

Help required with WLC software upgrade

+5 Pat!

as an side, Master Controller mode only has an effect when the AP do not have a configured primary/secondary/tertiary controller.

if these values are configured, MCM does nothing.

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Help required with WLC software upgrade

Thanks Stephen,

I have tried both the MCM and setting a primary and secondary controller, with the same results - the MCM was tried first, with somewhat scary results as the existing network fell over while the APs attempted to connect to the new WLC. fortunately I managed to pull it off the network in time.

Rob

New Member

Help required with WLC software upgrade

Hi Pat,

thanks for the reply. I am off site until the morning, but will attach the colsole output tomorrow.

Your mentioning a corrupt image makes me wonder - we had a lot of trouble setting up the initial config on the new WLC, getting a lot of launch failures. Eventually things seemed to settle down (it certainly booted successfully first time this morning) and getting an AP to connect without a problem made me hope it was just a quirk of the configuration wizard, but I think I will try a reboot of the WLC before I do anything else, just to check it is stable.

If it is a corrupt image it may take a little while to sort, as we have not as yet got a support contract on the 5508 - the plan was to upgrade the existing contract on the 4402 once they were swapped out, but I'll let you know whats going on

Rob

New Member

Help required with WLC software upgrade

Hi Pat,

I have just returned to site and power cycled the 5508 while connected to the CLI, and it has failed to launch either the primary or backup images, so it looks like either a software or, more likely, hardware fault.

I will arrnage for a replacement unit, which should solve the problem

Thanks to you and everyone else for your input

Rob

New Member

Help required with WLC software upgrade

Thanks for the speedy reply

I have now configured the mobility between the WLCs, and I will try the pre download when I am back on site tomorrow. I will keep you posted on the results

Rob

764
Views
5
Helpful
7
Replies