Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HP Interoperability

Hi I have a Cisco AP 1200 wireless Network. Now I'm trying to connect an HP IPAQ Hw514 mobile and I can't with WPA security or higher. But with an old 3com access point I have no problem to connect the HP IPAQ. Any idea?

I don't know if it can be useful to change some of the parameters of the acces point like Radio Preamble, Aironet Extensions, Ethernet Encapsulation transform, and so on.


joe Bronze

Re: HP Interoperability

I believe the ipaq's DO NOT support WPA. I believe they only support WEP.

I think your old 3com is using no security or WEP.

Please confirm.

New Member

Re: HP Interoperability

Well, what I can tell you all is this: indeed, HP iPAQ's support for WPA/WPA2 does not work properly or at all. The reason why I am saying this is that I've been working for a quite long period of time trying to authenticate a whole bunch of iPAQ rx3115 to some Cisco Aironet (1200AG and 1100) via WPA/TKIP or (preferably) WPA2/AES, and I haven't been successful. This is what I've tried to do so far:

1) First of all, my client's iPAQ device is fully up-to-date (everything);

2) 802.1X (PEAP/EAP-TLS) requires certificate, right? Guess what? This particular model of ours (rx3115) doesn't have its own certificate enrollment tool, and HP/Compaq does not offer such a tool for this series of pocket pcs. Some HP handhelds though do have a tool that you can download directly from website. What a joke: how do they offer 802.1x through EAP without any means of requesting certificates from CAs?

In my case, I found an interesting tool that does the job very well (google for Personal Certificate Import Utility for Pocket PC 2003 and Windows Mobile (P12imprt));

3) If I configure WEP on IPAQ, it works but WITHOUT 802.1x. Any attempt to 802.1x will hang up the iPAQ Wireless utility);

4) In order to find out alternative solutions to my case, based on the fact that HP doesn't have a native tool that would allow me to benefit from WPA2, I downloaded and tested some software, including SecureW2 (open source), Juniper's Odyssey (OAC), and the results were as follows:

- SecureW2 didn't work at all. I found out later that the rx3115 wasn't really supported, although nothing prevented me from testing SecureW2 with it.

- Juniper's Odyssey looked like interesting, but it worked only ONCE!!! Over a hundred attempts were made and in all of them the iPAQ rx3115 hanged big time.

Honestly, I do not know what else I could do about it. I definitely GIVE UP!

If anyone knows anything that could possibly convince me retaking all this painful process again, please lemme know! Until then... "IPAQ no more!".


Leonardo Furtado