Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

HWIC-3G-HSPA - NTT Docomo configuration

Anyone has configured successfully 3G/HSPA using Cisco 1841 HWIC-3G-HSPA to NTT Docomo network.

There is no username/password required.

APN: mopera.flat.foma.ne.jp

Below is my partial config. My cellular interface keeps reset between UP and Down status. The dialer shows SUCCESS and

the no. of dialing keeps going up.

=======================================

chat-script ntt "" ntt AT+CGDCONT=4,"PPP","mopera.flat.foma.ne.jp" timeout 5 OK "ATD*99***4#" TIMEOUT 30 "CONNECT"

interface Cellular0/1/0

no ip address

encapsulation ppp

dialer-in-band

dialer pool-member 1

dialer idle-timeout 0

async mode interactive

ppp ipcp dns request

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer string ntt

dialer persistent

dialer-group 1

ppp ipcp dns request

no cdp enable

access-list 1 permit ip any

dialer-list 1 protocol ip list 1

line 0/1/0

  script dialer ntt

=============== Working config from FITELnet 3G router - Japan ==========

interface dialer 1
max-call off
ip nat inside source list 1 interface
caller *99***4#
exit


interface mobile 1
idle-timer send off
idle-timer receive off
forced disconnect packet off
forced disconnect cumulative-time off
auto connect on continuous
card out-strings init 1 at+cgdcont=4,"PPP","mopera.flat.foma.ne.jp"
exit
!
end

Everyone's tags (1)
1 REPLY
Community Member

Re: HWIC-3G-HSPA - NTT Docomo configuration

I got it working and want to share with the community here.

Step 1: Create a GSM Profile for NTT Docomo

Step 2: Create a Chat Script

Step 3: Config the router

Step 4: Verification

Sidenote: NTT requires PPP CHAP authentication response with a "dummy" password to bring up PPP to get an ip address.

## Step 1 ###########################################################################

# No authentication, username, password in the SIM card. You need to unlock the sim card pin if any

####################################################################################

Router# cellular 0/1/0 gsm profile create 4 mopera.flat.foma.ne.jp

## Step 2 ###########################################################################

# Create a chat-script for NTT network

####################################################################################

chat-script ntt "" "ATD*99***4#" TIMEOUT 60 "CONNECT"

## Step 3 ###########################################################################

# Configure the router

####################################################################################


interface Cellular0/1/0
  no ip address
  encapsulation ppp
  dialer in-band
  dialer pool-member 1
  async mode interactive

interface Dialer1
  ip address negotiated
  ip virtual-reassembly
  encapsulation ppp
  dialer pool 1
  dialer idle-timeout 0
  dialer string ntt
  dialer persistent
  dialer-group 1
  ppp chap password 0 dummy
  ppp ipcp dns request

ip route 0.0.0.0 0.0.0.0 Dialer1

access-list 1 permit any
access-list 10 permit any
dialer-list 1 protocol ip list 1

line 0/1/0
exec-timeout 0 0
script dialer ntt
no exec

## Step 4 #####

Router#show cellular 0/1/0 all

Hardware Information
====================
Modem Firmware Version = K2_0_7_35AP C:/WS/F
Modem Firmware built = 03/04/10
Hardware Version = 1.0
International Mobile Subscriber Identity (IMSI) =
International Mobile Equipment Identity (IMEI) =
Factory Serial Number (FSN) =
Modem Status = Online
Current Modem Temperature = 46 deg C, State = Normal

Profile Information
====================
Profile 4 = ACTIVE
--------
PDP Type = IPv4
PDP address = x.x.x.x
Access Point Name (APN) = mopera.flat.foma.ne.jp
Authentication = None
Username: , Password:

* - Default profile

Data Connection Information
===========================
Data Transmitted = 145740 bytes, Received = 669946 bytes
Profile 1, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 2, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 3, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 4, Packet Session Status = ACTIVE
    IP address = x.x.x.x
    Negotiated QOS Parameters:
    Precedence = Normal Priority, Delay = Class 1
    Reliability = Unack GTP, Ack LLC, RLC, Protected data
    Peak = 256 kB/sec, Mean = 50000 kB/hr
    Traffic Class = Background
    Uplink Max = Unknown, Guaranteed = Subscribed
    Downlink Max = 14.4Mbps, Guaranteed = Subscribed
    Max SDU size = 1500 bytes
    SDU error ratio = 1E-6, BER = 6E-8
Profile 5, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 6, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 7, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 8, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 9, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 10, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 11, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 12, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 13, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 14, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 15, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state
Profile 16, Packet Session Status = INACTIVE
    Inactivity Reason = Normal inactivate state

Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = HSDPA (Attached)
Packet Session Status = Active
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = JPN, Network = DOCOMO
Mobile Country Code (MCC) = 440
Mobile Network Code (MNC) = 10
Location Area Code (LAC) = 27
Routing Area Code (RAC) = 0
Cell ID = 49281
Primary Scrambling Code = 417
PLMN Selection = Automatic
Registered PLMN = NTT DOCOMO , Abbreviated = DOCOMO
Service Provider =

Radio Information
=================
Current Band = WCDMA 2100, Channel Number = 10712
Current RSSI = -56 dBm
Band Selected = Auto
Number of nearby cells = 1
Cell 1
    Primary Scrambling Code = 0x1A1
    RSCP = -54 dBm, ECIO = -7 dBm


Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3

Router#show dialer

Ce0/1/0 - dialer type = IN-BAND ASYNC NO-PARITY
Dialer pool 1, priority 0
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Persistent Dialer Profile
Interface bound to profile Di1
Time until disconnect never
Current call connected 00:14:38
Connected to ntt

Di1 - dialer type = DIALER PROFILE
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 1

Dial String      Successes   Failures    Last DNIS   Last status
ntt                      1          0    00:14:38       successful   Default

Router#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  up                    down   
FastEthernet0/1            192.168.1.1     YES NVRAM  up                    up     
Serial0/0/0                unassigned      YES NVRAM  administratively down down   
Cellular0/1/0              unassigned      YES NVRAM  up                    up     
Dialer1                    x.x.x.x   YES IPCP   up                    up     
NVI0                       unassigned      YES unset  administratively down down  


Router#sho ip int c0/1/0
Cellular0/1/0 is up, line protocol is up
  Internet protocol processing disabled

4549
Views
0
Helpful
1
Replies
CreatePlease to create content