Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IPAD NOT CONNECTING TO AP 1142

Hello Guys, I have an ipad that is not able to connect to a 1142 Autonomous AP. This AP was originally a light weight AP and then downgraded to autonomous.A strange thing i see is that the AP shows me only two radios. 802.11 N(2.4 GHZ) and 802.11 N(5 GHZ). I suspected the AP not to support the b/g networks. i then downloaded the most recent software but i still cannot get it to connect and on the AP's GUI i only see the above two mentionned radios. i tried to connect to two SSID's. one using WPA2 and another with open authentication and no security.but this does not work. Is it possible that some 1142 do not support b/g networks?

any help is highly appreiated.

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

IPAD NOT CONNECTING TO AP 1142

increase DTIM to 10 or 75 radio preamble to long and disable aironet extension

radio preamble long

---

Posted by WebUser Danny Borpatragohain

21 REPLIES
Silver

IPAD NOT CONNECTING TO AP 1142

The 1142 does support b/g networks, it is simply labeled as 802.11 N.

We'll need more information about how you have the WLANs setup as well as the radios. Is this an iPad1 or 2?

New Member

IPAD NOT CONNECTING TO AP 1142

hello blakerone,

it is an ipad2 with ios 5. i have two SSID's.one for guests open authentication and another with WPA2 preshared key. I have the latest IOS installed. client PC connect normally without any issues with full network and internet connectivity. but with the ipad, i get a message saying that is is trying to connect. no IP address is received, and in the debug messages on the AP, i see authenticatiion starting and failing.

IPAD NOT CONNECTING TO AP 1142

Can you post the config of the AP?

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

IPAD NOT CONNECTING TO AP 1142

Hello Stephen

here it is;


!
version 12.4
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!

!
logging buffered 65535 debugging
no logging console

!
no aaa new-model
clock timezone cet 1
clock summer-time cdt recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
dot11 syslog
!
dot11 ssid xtreme
   vlan 15
   authentication open
   authentication key-management wpa version 2
   wpa-psk ascii cisco990?
!
dot11 ssid xtreme-guest
   vlan 20
   authentication open
!
dot11 arp-cache
!
crypto pki trustpoint TP-self-signed-3172633717
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3172633717
revocation-check none
rsakeypair TP-self-signed-3172633717
!
!
crypto pki certificate chain TP-self-signed-3172633717
certificate self-signed 01
  30820244 308201AD A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33313732 36333337 3137301E 170D3032 30333031 30323139
  32335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31373236
  33333731 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B341 FFA5D97C FF14DEEC 32689FAB AC8418ED 65138316 D6560275 23E25E77
  5A2AB2EF 4A9BC17C 098C0310 BF414FC6 CA201151 7D71E8A0 386402BA 055CE0B7
  8BE4E179 1ED5B1E8 F0DBB2EA 149A3AC2 72FC8373 FA976B76 79F85DE2 8D817E15
  5C7E6D33 E66AFF29 60DCD164 40F07CB9 6CE355EA 4C12BA29 63F6CBD8 CA7070E8
  4DB50203 010001A3 6C306A30 0F060355 1D130101 FF040530 030101FF 30170603
  551D1104 10300E82 0C536368 756C6D61 6E5F4150 32301F06 03551D23 04183016
  80146572 E97D10CD 163AF273 E3767819 299AF074 C7D6301D 0603551D 0E041604
  146572E9 7D10CD16 3AF273E3 76781929 9AF074C7 D6300D06 092A8648 86F70D01
  01040500 03818100 725801C1 C20AFDFE B7B00412 F768DD3F C6A32AD7 F3EC33EA
  4042C90D EF286704 E2E9EABF EB4C8A13 18FC345F DE416CEB F2EB81C8 615FEA37
  D8BE5742 85475AE7 D4EFB5EC A747E70A F6ABF07B 3E0C30AB FB1D3329 3BF022BB
  689A5C74 14AFF773 290EA752 BB82E701 3198371C B57C19E6 70643D6E 24BEE7FF
  C57A89D0 9135240D
  quit
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 15 mode ciphers tkip
!
ssid xtreme
!
ssid xtreme50
!
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.15
encapsulation dot1Q 15
no ip route-cache
bridge-group 15
bridge-group 15 subscriber-loop-control
bridge-group 15 block-unknown-source
no bridge-group 15 source-learning
no bridge-group 15 unicast-flooding
bridge-group 15 spanning-disabled
!
interface Dot11Radio0.20
encapsulation dot1Q 20
no ip route-cache
bridge-group 20
bridge-group 20 subscriber-loop-control
bridge-group 20 block-unknown-source
no bridge-group 20 source-learning
no bridge-group 20 unicast-flooding
bridge-group 20 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
!
encryption vlan 15 mode ciphers tkip
!
ssid xtreme
!
ssid xtreme-guest
!
antenna gain 0
no dfs band block
channel width 40-above
channel dfs
station-role root
bridge-group 1
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1.15
encapsulation dot1Q 15
no ip route-cache
bridge-group 15
bridge-group 15 subscriber-loop-control
bridge-group 15 block-unknown-source
no bridge-group 15 source-learning
no bridge-group 15 unicast-flooding
bridge-group 15 spanning-disabled
!
interface Dot11Radio1.20
encapsulation dot1Q 20
no ip route-cache
bridge-group 20
bridge-group 20 subscriber-loop-control
bridge-group 20 block-unknown-source
no bridge-group 20 source-learning
no bridge-group 20 unicast-flooding
bridge-group 20 spanning-disabled
!
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
no keepalive
!
interface GigabitEthernet0.15
encapsulation dot1Q 15
no ip route-cache
bridge-group 15
no bridge-group 15 source-learning
bridge-group 15 spanning-disabled
!
interface GigabitEthernet0.17
description *** Management Vlan ***
encapsulation dot1Q 17 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0.20
encapsulation dot1Q 20
no ip route-cache
bridge-group 20
no bridge-group 20 source-learning
bridge-group 20 spanning-disabled
!
interface BVI1
ip address 172.100.17.50 255.255.255.0
no ip route-cache
!
ip default-gateway 172.100.17.254
no ip http server
ip http authentication local
ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
logging 172.17.15.16
snmp-server community 87e5f6a953 RW
bridge 1 route ip
!
!

line con 0
login local
line vty 0 4
login local

end

New Member

IPAD NOT CONNECTING TO AP 1142

hello blakerone,

it is an ipad2 with ios 5. i have two SSID's.one for guests open authentication and another with WPA2 preshared key. I have the latest IOS installed. client PC connect normally without any issues with full network and internet connectivity. but with the ipad, i get a message saying that is is trying to connect. no IP address is received, and in the debug messages on the AP, i see authenticatiion starting and failing.

Hall of Fame Super Silver

Re: IPAD NOT CONNECTING TO AP 1142

Your using wpa2/aes correct?

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
New Member

IPAD NOT CONNECTING TO AP 1142

I am using WPA-PSK and TKIP

New Member

IPAD NOT CONNECTING TO AP 1142

Scott, it is WPA2-PSK and i am using TKIP which i think is the dafault for WPA2?

thanks for the help

Hall of Fame Super Silver

Re: IPAD NOT CONNECTING TO AP 1142

No... wpa uses tkip and wpa2 uses aes

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***

Re: IPAD NOT CONNECTING TO AP 1142

On the 5GHz radio set your channel to be something other than DFS, like channel 36.

Steve

Sent from Cisco Technical Support iPad App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Silver

IPAD NOT CONNECTING TO AP 1142

increase DTIM to 10 or 75 radio preamble to long and disable aironet extension

radio preamble long

---

Posted by WebUser Danny Borpatragohain

Silver

IPAD NOT CONNECTING TO AP 1142

change:preamble to long , disable aironet extension, DTIM to 10 or 75

Radio pream

---

Posted by WebUser Danny Borpatragohain

New Member

IPAD NOT CONNECTING TO AP 1142

Please forgive me if the etiquitte is to start a new post but I am having the EXACT issue the thread-starter was so I was hoping to get help on this thread since several experts with this issue seem to already be in place here.

Info:

* WAP running latest firmware

* I have two SSIDs (Internal and Guest)

* Both SSIDs use WPA2 and AES-CCM. 

My radio config, after reading the tips above, looks like this:

--

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 2 mode ciphers aes-ccm

!

encryption vlan 3 mode ciphers aes-ccm

!

ssid Guest

!

ssid Internal

!

antenna gain 0

mbssid

no preamble-short

station-role root

beacon dtim-period 75

no dot11 extension aironet

--

My desktops/laptops can connect to both SSIDs all day with no problem, but when I try to connect any iDevice, it asks for the password, seems to take it fine, and then just "spins" forever, never to get an IP.  If I look at associations from an SSH session, I see:

--

SSID [Guest] :


MAC Address    IP address      Device        Name            Parent         Stat

c09f.xxxx.xxxx 0.0.0.0         unknown       -               self           Assoc

--

(The C09f.xxxx.xxxx is my iPhone that will never get an IP).

Please help if you have any ideas, or direct me to create a new thread and I'll certainly do that.

Thanks,

Brian

Hall of Fame Super Silver

Re: IPAD NOT CONNECTING TO AP 1142

Try lowering your dtim to 2

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***
New Member

Re: IPAD NOT CONNECTING TO AP 1142

Scott,

Thanks, I will double check but I believe that's what it was set to, and I have also tried both 10 and 75 per recommendations on another thread.

Brian

Hall of Fame Super Silver

Re: IPAD NOT CONNECTING TO AP 1142

That is pretty high.... default is at 1 and usuallly can be set to 2 with no issues.

-Scott
*** Please rate helpful posts ***
New Member

IPAD NOT CONNECTING TO AP 1142

Scott thanks for your help.  After talking with Cisco yesterday and also taking your DTIM recommentation into consideration, my radio settings are:

--

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 2 mode ciphers aes-ccm

!

encryption vlan 3 mode ciphers aes-ccm

!

ssid Guest

!

ssid Internal

!

antenna gain 0

mbssid

station-role root

beacon dtim-period 1

no dot11 extension aironet

--

Argh...any other ideas?

Thanks,

Brian

IPAD NOT CONNECTING TO AP 1142

I saw sometimes problem with hidden SSIDs I didn't see in the config that you broadcast your SSID. With that command

mbssid guest-mode dtim-period 75

you broadcast your ssid, just give them a try maybe.

regards,

Sebastian

New Member

Re: IPAD NOT CONNECTING TO AP 1142

Thanks Sebastian.  Both SSIDs for the two VLANs are broadcast.

Brian

New Member

IPAD NOT CONNECTING TO AP 1142

Did you ever get it to work?  If so what was the solution to your issue?  I am having a similar issue.

New Member

IPAD NOT CONNECTING TO AP 1142

jwinters99,

For me, my issue was the device handing out DHCP.  For my network it was served out by the Watchguard, and as I wrote above, iDevices (as well as Androids and most laptops) would never get an address properly, but DID work if I set them static.  So, we chalked it up to a Watchguard thing, because as soon as we yanked the DHCP role off the WG and put it on our core switch, ALL the devices started working correctly immediately.

Brian

2589
Views
3
Helpful
21
Replies