Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Is point-to-multipoint(5GHz)+wifi(2.4GHz) with 4 air AP1242AG possible and how?

Hello,

I have a little experience with cisco routers but none with the air AP1242AG.

The project i am working now is about giving wifi to a village. There is one ADSL router, one switch (2690) and several AP1242AG.

Is it possible to have the following topology?

topology.jpg

Can i use one of the AP as a master and connect through a sector antenna the other access points using the 5GHz interface, and also use the 2.4GHz interface for hosts to connect?


Can you help with the configuration for both the "master AP" and the "client APs"? if you have a similar configuration it would vey much appreciated.

Thank you very much for your time.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Is point-to-multipoint(5GHz)+wifi(2.4GHz) with 4 air AP1242A

Yes it is possible to bridge on the 5ghz and have client access on the 2.4ghz. Now having a working config to show you is a bit difficult. Here are a few links that should help. The main thing is that you setup the 5ghz as a bridge and the role would be root bridge and all the other would be non root bridge. The client access would be root access point

https://supportforums.cisco.com/docs/DOC-16087

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a008058f53e.shtml

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
5 REPLIES
Hall of Fame Super Silver

Re: Is point-to-multipoint(5GHz)+wifi(2.4GHz) with 4 air AP1242A

Yes it is possible to bridge on the 5ghz and have client access on the 2.4ghz. Now having a working config to show you is a bit difficult. Here are a few links that should help. The main thing is that you setup the 5ghz as a bridge and the role would be root bridge and all the other would be non root bridge. The client access would be root access point

https://supportforums.cisco.com/docs/DOC-16087

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a008058f53e.shtml

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***

Is point-to-multipoint(5GHz)+wifi(2.4GHz) with 4 air AP1242AG po

Hi Scott

Thank you very much for this, i am working on these examples now.

I was trying to find something like this but i couldn 't in the "chaotic" Cisco tutorials and guides.

And another question.

Do i have to use a different Vlan for each non toute bridge 1242 in order to have point to multipoint?

Thanks again

Alex

Hall of Fame Super Silver

Is point-to-multipoint(5GHz)+wifi(2.4GHz) with 4 air AP1242AG po

Well just remember that all autonomous ap's require that the ap management ip address is the native vlan, if you plan on separating the managment vlan from wireless user traffic.  If you don't care, you can have the wireless users and the ap on the same vlan and you just have to configure an ip address with no subinterfaces on the AP.

Here is a link on how to setup multiple vlans:

https://supportforums.cisco.com/docs/DOC-14496

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***

Is point-to-multipoint(5GHz)+wifi(2.4GHz) with 4 air AP1242AG po

Hi Scott,

I din't quite unerstand what you mean. I only have the native Vlan 1

My problem is that when i set the AP's to Non root bridge mode, the interface dot11radio 1 goes down and is in reset state. If i set it to root bridge it goes up. Am i missing something else in my configuration? i tried to follow the examples you posted.

Do you think if i posted the configurations might help?

Thank you.

Alex

Re: Is point-to-multipoint(5GHz)+wifi(2.4GHz) with 4 air AP1242A

Hi Scott,

I finally realized why the dot11Radio 1 interface wouldn't go up, it needed to authenticate with the root AP 's interface.

I had tried open auth, open auth with mac and LEAP, but it didn't work (maybe my config was wrong).

So i set wpa2 authentication between the 5GHz interfaces and everything worked.

I left everything (management and hosts) on the native vlan as you set, maybe I'll put the hosts on a different vlan later, for security reasons.

I am posting my configuration so if you see something wrong, unnecessary or missing please let me know.

root bridge

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname BaseAP

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

aaa session-id common

!

!

!

dot11 ssid bridging

   vlan 1

   authentication open

   authentication key-management wpa version 2

   guest-mode

   infrastructure-ssid

   wpa-psk ascii key

!

!

dot11 ssid fotolivosHotspot

   authentication open

   guest-mode

!

power inline negotiation prestandard source

!

!

username user1 privilege 15 password pass1

username user2 privilege 15 password pass2

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid fotolivosHotspot

!

antenna transmit right

antenna receive right

antenna gain 6

channel 2412

station-role root access-point

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption vlan 1 mode ciphers aes-ccm tkip

!

encryption mode ciphers aes-ccm tkip

!

ssid bridging

!

antenna gain 8

dfs band 1 3 block

channel dfs

station-role root bridge

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

!

interface BVI1

ip address 192.168.1.253 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.254

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

And the configuration of one of the non root bridge AP's

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname StationAP1

!

enable secret pass

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

aaa session-id common

!

!

!

dot11 ssid bridging

   vlan 1

   authentication open

   authentication key-management wpa version 2

   infrastructure-ssid

   wpa-psk ascii "key"

!

dot11 ssid fotolivosHotspot

   authentication open

   guest-mode

!

power inline negotiation prestandard source

!

!

username user1 privilege 15 password pass1

username user2 privilege 15 password pass2

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid fotolivosHotspot

!

antenna transmit right

antenna receive right

antenna gain 8

channel 2437

station-role root access-point

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm tkip

!

encryption vlan 1 mode ciphers aes-ccm tkip

!

ssid bridging

!

antenna transmit right

antenna receive right

antenna gain 8

station-role non-root

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.1.252 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.254

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

Thanks again for the help

BR

Alex

1016
Views
0
Helpful
5
Replies