Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Multiple VLANs on c1200

Hello,

I've configured 2 VLANs on cisco 1200 AP. One native (vlan 1) and tagged with vlan 2 tag. I created DHCP pool and i don't get IP address for encapsulated VLAN while i do for native.

My configuration:

Building configuration...

Current configuration : 2255 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret xxx

!

ip subnet-zero

ip dhcp excluded-address 10.60.129.1 10.60.129.60

ip dhcp excluded-address 192.168.1.1 192.168.1.2

!

ip dhcp pool dhcp-pool

network 10.60.129.0 255.255.255.0

default-router 10.60.129.1

!

ip dhcp pool mngmt

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

!

aaa new-model

!

!

aaa session-id common

!

dot11 ssid WHEP1a

vlan 1

authentication open

!

dot11 ssid mngmt

vlan 2

authentication open

!

!

!

username Cisco password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 40bit xxxtransmit-key

!

ssid WHEP1a

!

ssid mngmt

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

channel 2412

station-role root ap-only

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.2

encapsulation dot1Q 2

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface BVI1

ip address 10.60.129.55 255.255.255.0

no ip route-cache

!

interface BVI2

ip address 192.168.1.2 255.255.255.0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

IOS running is: C1200-K9W7-M,Version 12.3(8)JEB

Any suggestions?

Tnx for any help.

4 REPLIES
Silver

Re: Multiple VLANs on c1200

Here is the configuration guide for the Cisco AP. Follow the configuration guide which will help you :

http://www.cisco.com/en/US/docs/wireless/access_point/12.4_10b_JA/configuration/guide/scg12410b-chap4-first.html#wp1051166

Bronze

Re: Multiple VLANs on c1200

I'm having a similar issue - how did you fix this problem? thx

Green

Re: Multiple VLANs on c1200

The AP only supports services for a single scope for DHCP, and only for the native VLAN.

For more than that you need to set up a separate server.

Good Luck

Scott

Bronze

Re: Multiple VLANs on c1200

Scott

When I search the netpro wireless forum, there are other folks who have a inside admin vlan/ssid and a guest vlan/ssid that "seem" to have fix this dhcp problem.

If it is only on native vlan, what is the purpose of multiple ssid/vlan/bridge-groups configs on the AP while the upstream switch is setup as a trunk port?

319
Views
0
Helpful
4
Replies
CreatePlease login to create content