Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need help with troubleshooting on 1200

I have set up a 1200 (image c1200-k9w7-tar.123-7.JA) with multiple SSIDs, one of which is intended to be completely open;

dot11 ssid bfopen

vlan 69

authentication open

guest-mode

!

This works perfectly for most clients (Windows, Linux) but a HP IPAQ rx3715 will not maintain an association. It sees the SSID and tries to connect but the association drops after a matter of seconds. The DHCP server on that VLAN sees a request from the IPAQ and replies, but by then the connection is gone.

I did some debugging on the 1200 which shows the following;

Nov 14 16:14:28.848: dot11_mgr_disp_wlccp_update_auth: unknown auth type 0x1

Nov 14 16:14:28: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 0012.7999.ded8 Associated KEY_MGMT[NONE]

Nov 14 16:14:36.682: dot11_dot1x_gtk_update_on_disassociate: Recieved gtk update notice due to disconnect for 0012.7999.ded8 on vlan 69

Nov 14 16:14:36: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0012.7999.ded8 Reason: Previous authentication no longer valid

Nov 14 16:14:36.688: dot11_mgr_disp_wlccp_update_auth: unknown auth type 0x1

Nov 14 16:14:36: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 0012.7999.ded8 Associated KEY_MGMT[NONE]

Nov 14 16:14:42.561: dot11_dot1x_gtk_update_on_disassociate: Recieved gtk update notice due to disconnect for 0012.7999.ded8 on vlan 69

Nov 14 16:14:42: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0012.7999.ded8 Reason: Previous authentication no longer valid

Nov 14 16:14:42.567: dot11_mgr_disp_wlccp_update_auth: unknown auth type 0x1

Nov 14 16:14:42: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 0012.7999.ded8 Associated KEY_MGMT[NONE]

Nov 14 16:14:49.567: dot11_dot1x_gtk_update_on_disassociate: Recieved gtk update notice due to disconnect for 0012.7999.ded8 on vlan 69

Nov 14 16:14:49: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0012.7999.ded8 Reason: Previous authentication no longer valid

[loads more entries exactly like these...]

I really need help in identifying why this client has problems but all the others are OK. Can anyone suggest what more I can do to identify why this client is constantly being deauthenticated?

Thanks,

Colin

5 REPLIES
New Member

Re: Need help with troubleshooting on 1200

What are the radio preamble settings on your access point?

Cheers,

Pablo

New Member

Re: Need help with troubleshooting on 1200

What are the preamble settings on your access point?

Cheers,

Pablo

New Member

Re: Need help with troubleshooting on 1200

Pablo,

Radio preamble is set to Short (default). Other settings are;

traffic-class background cw-min 5 cw-max 8 fixed-slot 3

traffic-class best-effort cw-min 5 cw-max 8 fixed-slot 2

traffic-class video cw-min 4 cw-max 6 fixed-slot 2

traffic-class voice cw-min 3 cw-max 7 fixed-slot 2

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

power local cck 10

power local ofdm 10

power client 10

packet retries 32

fragment-threshold 2338

station-role root

rts threshold 2339

rts retries 32

beacon period 4000

no dot11 extension aironet

no cdp enable

infrastructure-client

Regards,

Colin

New Member

Re: Need help with troubleshooting on 1200

Hi Colin,

It could be the wireless card you are using on the IPAQ rx3715 that doesn’t support short preambles. Change the radio preamble to short and see what happens, if your WLAN is not heavily utilize this change shouldn’t impact much of the performance. Let me know...

Thk,

Pablo

New Member

Re: Need help with troubleshooting on 1200

I have just changed the Preamble from Short to Long, but the behaviour is still the same. Looking at the iPAQ, it sees the SSID, associates with it (signal about -50dBm), and then a couple of seconds later it has no signal. A couple of seconds later it sees the SSID and this just goes on and on. The AP is about 2 or 3 metres away from me.

What's worse is that I can't get the AP to show me anything useful using the debug commands. I am connected to the console and have the following debug set;

Dot11Radio 0

Receive packet trace will print

Transmit packet trace will print

Beacons will be displayed

Probe request/responses will be displayed

Ack/Cts/Rts will be displayed

Crc errors will be displayed

PLCP header will not be displayed

IV will be displayed

CKIP MIC will be displayed

only last 3 bytes of mac addresses printed

Entire packet will be displayed in hex

2 lines of packet data will be displayed

dot11:

IEEE 802.11 packets debugging is on

beacon and probe reponse debugging is on

But I see no output exept the the usual;

Dec 1 17:09:06: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 0012.7999.ded8 Associated KEY_MGMT[NONE]

Dec 1 17:09:12: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0012.7999.ded8 Reason: Previous authentication n

o longer valid

Dec 1 17:09:12: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 0012.7999.ded8 Associated KEY_MGMT[NONE]

Dec 1 17:09:19: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 0012.7999.ded8 Reason: Previous authentication n

o longer valid

Any suggestions gratefully received.

Regards,

Colin

481
Views
0
Helpful
5
Replies
CreatePlease to create content