Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

No HTTPS after 1232AG IOS Upgrade

Whenever I upgrade one of our autonomous 1232AG APs, I lose the ability to https to the device for the managment utility. I can SSH to it and if I turn off http secure-server and enable http server, I can use http to manage it no problem. Here's what I've done:

archive download-sw /overwrite /reload tftp://192.168.1.2/c1200-k9w7-tar.123-8.JEC.tar

Here's what I've tried:

no ip http server

ip http secure-server

<still no https:>

-------

no ip http secure-server

ip http server

<after these two commands http works fine>

crypto ken generate rsa <1024>

AP# dir flash:c1200-k9w7-mx.123-8.JEC

Directory of flash:/c1200-k9w7-mx.123-8.JEC/

7 drwx 64 Mar 02 2002 00:07:20 +00:00 html

151 -rwx 3677224 Mar 02 2002 00:08:47 +00:00 c1200-k9w7-mx.123-8.JEC

152 -rwx 131328 Mar 02 2002 00:08:49 +00:00 5001.img

153 -rwx 131328 Mar 02 2002 00:08:51 +00:00 5101.img

154 -rwx 131328 Mar 02 2002 00:08:53 +00:00 6301.img

155 -rwx 131328 Mar 02 2002 00:08:56 +00:00 6701.img

156 -rwx 131328 Mar 02 2002 00:08:58 +00:00 6701_cal.img

157 -rwx 274 Mar 02 2002 00:08:58 +00:00 info

7741440 bytes total (2721280 bytes free)

Any ideas?

2 REPLIES

Re: No HTTPS after 1232AG IOS Upgrade

I am not too sure, I always use the flag exportable when I generate my rsa keys, because an obscure corner of my mind keeps the idea that if you don't set the exportable flag, the key pair will not be maintained when you upgrade the IOS... and of course, no rsa key, no https...

might also depend which IOS version you upgrade from... give it a try...

Community Member

Re: No HTTPS after 1232AG IOS Upgrade

Thanks, I tried it - no joy :-(

197
Views
0
Helpful
2
Replies
CreatePlease to create content