Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Predownload issue

I am upgrading from 7.0.98 to 7.0.116

I have downloaded the code to the controller.  I  predownloaded the code to the access points.  I did a image swap, but  the AP's still show 7.0.98 as primary and now the backup image as well, with 7.0.116 as  the predownloaded image.  Why don't they show 7.0.116 as the primary  like the documentation suggests?

Thanks in advance!

Tony

25 REPLIES
Silver

Predownload issue

When you do the AP predownload you don't need to click on the swap image button, that will actually make it so that your backup image is the 7.0.116. The AP predownload has an implicit swap built in, so the image you are predownloading will become the primary. I bet if you look at the AP details it'll say primary image 7.0.98 and backup 7.0.116.

Re: Predownload issue

Here is my 2 cents ..

I just upgraded 40 WLCs from 7.0.98.0 to 7.0.220.0.

When you upgrade a WLC the code goes to primary.

When you upgrade an access point, I think it goes to backup. In any case you want it as primary. You can do a >show ap image all and you will see the position the code is in.

Ive played with this for atleast 2 hours. I even emailed Wesley. I think there is a bug on the predownload image on 7.0.98.0.

Let me ask you. After you did your predownload and you did an ap swap back and forth. Did you EVER see 7.0.116.0 as your primary. No, right?

Also there is an error in some of the wording in the predownload section of the 7.x config guide.

I blogged about the predownload process... in case you ever need something to reference.

http://www.my80211.com/cisco-wlc-cli-commands/2011/2/20/wlc-predownload-the-image-to-the-access-points-from-the-cont.html

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
Silver

Re: Predownload issue

Intriguing George, I'll have to lab that. I've never had an issue with AP preimage download going from 7.0.98 to 7.0.220, all my APs switched images just like expected.

Re: Predownload issue

It was first brought to my attention by one of my customers and just discounted as user error. And then 2 weeks later i needed to push code to the enterprise and experienced the same thing. User error on my part, maybe, but after 2 hours of trying different methods i could not get the ap code to move to primary.

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
New Member

Re: Predownload issue

Nope, the downloaded code only shows up as predownloaded version.

                                                 Predownload     Predownload

AP Name            Primary Image  Backup Image   Status          Version        Next Retry Time  Retry Count

------------------        --------------         --------------         ---------------     --------------     ----------------          ------------

Tyl-AP-6N-F0/41    7.0.98.0         7.0.98.0           Complete       7.0.116.0      NA                     NA  

I've swapped back and forth, downloaded primary and backup images, swapped back and forth again, but 7.0.116 NEVER shows under primary image.

ARGGG....

Oh, and here is the show boot:

(WiSM-slot1-1) >show boot

Primary Boot Image............................... Code 7.0.116.0 (active)

Backup Boot Image................................ Code 7.0.98.0 (default)

New Member

Re: Predownload issue

George, did you ever talk to TAC?  That may be my next task... talking to someone who knows less about WLC's than we do! :/

sidenote:  I can read from a manual too, can I go work for Cisco?

Re: Predownload issue

Ouch, no love for tac? Did you have a bad experience ? Almost all the tac guys I deal with are great.

No I didn't open a tac case. But you confirm for me that it wasn't user error.

I was under the gun and my change management window was short.

Sent from Cisco Technical Support iPhone App

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
Silver

Re: Predownload issue

Don't take this the wrong way but you did reboot the WLC correct?

Re: Predownload issue

Lol we are all friends here Blake. You shouldn't have to reboot the wlc and never did in the past. Not sure I am picking up what your dropping bud ..

Sent from Cisco Technical Support iPad App

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
Silver

Re: Predownload issue

You still need to reboot the controller for all this to work. The preimage download simply stages the code so you don't have large downtimes with your APs downloading code after the reboot.

New Member

Re: Predownload issue

Blake,

I haven't rebooted yet because the AP's don't show the correct image as primary.

I did set the AP to join a controller which is already upgraded, but it wouldn't move over.  So, I reloaded the AP to see what happened.  Just as expected, the AP had to "download" the code again and reboot, which is not what I wanted.  This would take forever with 500 access points and the downtime would be rediculous... mgmt would cringe if I asked for a couple of hours of downtime to upgrade the AP's.  The last time we upgraded was "supposed" to reduce downtime, or that's what I told them...

To say the least, I'm frustrated.  I may have to reload a few AP's at a time and let them join the WiSM's that are upgraded.

Wonder how long that's going to take.

George, I've never had much luck with TAC and wireless.  R&S is usually fine, but wireless.... geeeesh!

Re: Predownload issue

Tony

I did 3000 ap upgrade because of this problem. It took me maybe 30 minutes. Each wlc will upgrade 10 at a time. If you move aps and mix code during your upgrade could cause problems with clients on the floor. How many controllers do you have. That will really determine how long.

Sent from Cisco Technical Support iPad App

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
Silver

Re: Predownload issue

Does look like a bug Tony, I just tried going 7.0.98 to 7.0.220 on my 4402 with an 1131 and 1142. I was able to get the controller to take the new code with no issues, then doing the predownload neither AP would show backup image switched to 7.0.220. Somehow after 4 config ap image swap's I was able to get the 1131 to show 7.0.220 as primary. I can't get the 1142 to switch over though.

After rebooting the controller the 1131 did come right up without downloading but the 1142 required the download.

I would open a TAC case and reference this thread.

(RL-C4402-01) >config ap image predownload primary all

(RL-C4402-01) >show ap image all

Total number of APs.............................. 2
Number of APs
     Initiated....................................... 0
     Predownloading.................................. 2
     Completed predownloading........................ 0
     Not Supported................................... 0
     Failed to Predownload........................... 0

                                                 Predownload     Predownload
AP Name            Primary Image  Backup Image   Status          Version        Next Retry Time  Retry Count
------------------ -------------- -------------- --------------- -------------- ---------------- ------------
RL-IE-C1131-01     7.0.98.0       3.0.51.0       Predownloading  7.0.220.0      NA               NA          
RL-IE-C1142-01     7.0.98.0       0.0.0.0        Predownloading  7.0.220.0      NA               NA

(RL-C4402-01) >show ap image all

Total number of APs.............................. 2
Number of APs
     Initiated....................................... 0
     Predownloading.................................. 0
     Completed predownloading........................ 2
     Not Supported................................... 0
     Failed to Predownload........................... 0

                                                 Predownload     Predownload
AP Name            Primary Image  Backup Image   Status          Version        Next Retry Time  Retry Count
------------------ -------------- -------------- --------------- -------------- ---------------- ------------
RL-IE-C1131-01     7.0.98.0       3.0.51.0       Complete        7.0.220.0      NA               NA          
RL-IE-C1142-01     7.0.98.0       0.0.0.0        Complete        7.0.220.0      NA               NA
New Member

Re: Predownload issue

Prior to doing any image swap this is what is shown...

(WiSM-slot1-2) >show boot

Primary Boot Image............................... Code 7.0.116.0 (active)

Backup Boot Image................................ Code 7.0.98.0 (default)

(WiSM-slot1-2) >show ap image Quit-MDF-AP2-F0/2      

Total number of APs.............................. 65

Number of APs

        Initiated....................................... 0

        Predownloading.................................. 0

        Completed predownloading........................ 65

        Not Supported................................... 0

        Failed to Predownload........................... 0

                                                 Predownload     Predownload

AP Name            Primary Image  Backup Image   Status          Version        Next Retry Time  Retry Count

------------------ -------------- -------------- --------------- -------------- ---------------- ------------

Quit-MDF-AP2-F0/2  7.0.98.0      0.0.0.0       Complete        7.0.116.0      NA               NA

After config ap image swap...

(WiSM-slot1-2) >show ap image Quit-MDF-AP2-F0/2      

Total number of APs.............................. 65

Number of APs

        Initiated....................................... 0

        Predownloading.................................. 0

        Completed predownloading........................ 65

        Not Supported................................... 0

        Failed to Predownload........................... 0

                                                 Predownload     Predownload

AP Name            Primary Image  Backup Image   Status          Version        Next Retry Time  Retry Count

------------------ -------------- -------------- --------------- -------------- ---------------- ------------

Quit-MDF-AP2-F0/2  7.0.98.0       7.0.98.0       Complete        7.0.116.0      NA               NA


 

New Member

Predownload issue

Opened a TAC case and so far they have been very helpful.  I should go on to say that not every wireless case with TAC is horrible, but there are some guys that have no business taking cases. 

I'm sure my frustration yesterday got the best of me, so I needed to clarify that TAC in general is great... but I have had some not so great experiences.

Will update when I have more info from TAC.

Thanks,Tony

New Member

Predownload issue

@Tony,

Tony any update on your progress?  I am currently running 5508 with version 7.0.116.0.  When I try to predownload a backup image to my APs nothing happens, actually one of 59 pre downloaded.

I have tried several times. 

(Cisco Controller) >show ap image all                     

Total number of APs.............................. 59
Number of APs
        Initiated....................................... 0
        Predownloading.................................. 0
        Completed predownloading........................ 1
        Not Supported................................... 0
        Failed to Predownload........................... 0

                                                 Predownload     Predownload
AP Name            Primary Image  Backup Image   Status          Version        Next Retry Time  Retry Count
------------------ -------------- -------------- --------------- -------------- ---------------- ------------
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA         
xxxxxxxxx            7.0.116.0      0.0.0.0        None            None           NA               NA

xxxxxxxxx            7.0.116.0      7.0.116.0      Complete        7.0.116.0      NA               NA         

New Member

Re: Predownload issue

I completely forgot to update this...

According to TAC, this is an unresolved bug that started in a previous code release.  I am currently running 7.0.116.0, that was to get past a bug in 7.0.98.0.  I am planning to upgrade to 7.0.220.0 to fix the VLAN Select feature(interface group).  So I can't confirm whether 7.0.116.0 will give me the same problem as 7.0.98.0 did in my original post.

How I fixed 7.0.98.0:

If you log into an Access Point, you'll see that the code really did upload.  The bug exists where the WLC is supposed to issue the boot system flash command and tell the AP to boot the new image.

I use SecureCRT as a telnet manager.  So, I modified a script that logs in to the AP's directly, changes the boot sys flash variable to run the new image, writes the config to memory, and exits.  It reads a list of devices from a text file that I populated with a device report from WCS.  I know all of this may sound complicated, but it's not.  It's certainly better than manually logging into 500 AP's to do this. 

It appears that I can't attach any files here, so I'll paste the code for others to use if they need it.  As far as I know, this only works with SecureCRT, but you may be able to run it if other telnet managers run scripts.

FYI, I had to manually upgrade at least one AP to get the software version that I put in the SecureCRT.vbs

Thanks,

Tony

New Member

Predownload issue

Actually, I was able to upload to my profile area...

https://supportforums.cisco.com/servlet/JiveServlet/downloadBody/23686-102-1-58571/scripts.zip

If that link doesn't work, go check my profile.

New Member

Predownload issue

WOW!!!  Very cool.  I will give it a shot.

Thanks

New Member

Predownload issue

Let me know if I can answer any questions...

Re: Predownload issue

Learn something new today! Thanks Tony I am going to take a peek at this over the weekend. +5

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
New Member

Re: Predownload issue

Glad I could help... that's a first for me I think(being on the helping end)

New Member

Predownload issue

This saved my butt. Thanks Tony. I tried finding the bug on Cisco's site but nothing. Have the number just for reference?

New Member

Re: Predownload issue

I can't recall what the actual bug ID is... sorry. Glad the script worked out for you!

Tony

>>> dkorell 6/4/2012 6:29 PM >>>

Home ( https://supportforums.cisco.com/index.jspa )

Re: Predownload issue created by dkorell ( https://supportforums.cisco.com/people/dkorell ) in Other Wireless - Mobility Subjects - View the full discussion ( https://supportforums.cisco.com/message/3652284#3652284 )

This saved my ****. Thanks Tony. I tried finding the bug on Cisco's site but nothing. Have the number just for reference?

Reply to this message by going to Home ( https://supportforums.cisco.com/message/3652284#3652284 )

Start a new discussion in Other Wireless - Mobility Subjects at Home ( https://supportforums.cisco.com/choose-container!input.jspa?contentType=1&containerType=14&container=2043 )

===========================================================

This message is confidential, intended only

for the named recipient(s) and may contain

information that is privileged or exempt from

disclosure under applicable law. If you are

not the intended recipient(s), you are notified

that the dissemination, distribution or copying

of this message is strictly prohibited. If you

received this message in error, or are not the

named recipient(s), please notify the sender

and delete this e-mail from your computer.

ETMC has implemented secure messaging for

certain types of messages. For more information

about our secure messaging system, go to:

http://www.etmc.org/mail/

Thank you.

===========================================================

Predownload issue

Tony

+5!

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
1781
Views
25
Helpful
25
Replies
CreatePlease to create content