Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Printer won't connect to wifi

Hello

I've recently bought Samsung m2020/2020w  wireless printer, but I cannot seem to connect it to wifi. When trying to connect via WPS, then wireless setup light keeps flasing for 2 minutes but won't connect. Also tried to connect the printer to wifi through my PC via cable, but that gives me "general error". Sent my printer for warranty repair, but it came back as OK (they managed to connect it to their wireless networks). I've switched off my windows firewall, tried firmware update on the printer and connecting it to the router using laptop. Wifi works okay with other wireless devices such as smartphones and laptops.

Im using Cisco epc3825 router.

2 REPLIES

Printer won't connect to wifi

Hello,

what band the printer is using (2.4 or 5 GHz)?

What is the security on the wireless network that you use?

have you tried to connect the printer withour WPS?

because it gives you a general error in wired side, I think your problem is bigger than wireless-only issue.

I think it is better to move your post to the small business->wireless forms that is responsible for your device type.

Regards,

Amjad

Rating useful replies is more useful than saying "Thank you"

Rating useful replies is more useful than saying "Thank you"
New Member

Printer won't connect to wifi

Hi,

Printer uses IEEE 802.11b/g/n protocol for wifi, which should be 2.4Ghz.

Security is set to "WPA or WPA2 Personal". I also tried other security settings and turning off wireless security all together, still no connection.

Yes, I've tried connecting via cable (Printer connected to PC via cable and PC connected to router), but that gave me general error as well.


I also tried assigning printer's ip manually but I wasn't very sure what I was doing and it didn't work.

8378
Views
0
Helpful
2
Replies