Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem encountered in upgrading Cisco 1100s wireless access point

Here is the info about the 1100s AP I have in the office:

Product/model number: AIR-AP1120B-A-K9

Part number: 73-7886-04

Basically I was trying to upgrade the system software from 1100-k9w7-tar.123-2.JA2 to the latest version of c1100-k9w7-tar.123-7.JA2. At first I tried to use the web interface to upgrade the software in the system software/software upgrade page. Nonetheless I waited for good 5 minutes and nothing happened. I then resort to using the command line interface to upgrade by typing "copy tftp://ip_address of tftpserver/c1100-k9w7-tar.123-7.JA2 flash:" (I thought the command in this AP OS will be similar to the router or PIX IOS). At first the file transfer aborted in the middle and I thought there was not enough space in the flash. I then did the unthinkable - I started doing delete /recursive in the directory of

1100-k9w7-tar.123-2.JA2 (existing system software version) in flash. After I removed all the files inside I was then successful in copying the new version of the software successfully to flash. After the transfer I then reloaded the AP and since then it will not come back up.

At that point I figured I must have done something incredibly dumb (probably with the deleting of image files in flash) so I went looking for restore procedure on Cisco's page. I followed exactly as what Cisco says in restoring to manufacturer's settings (by holding down the mode button for 30 seconds while re-connecting the power). I hold the mode button down until the status light turn red and then released the mode button. Thereafter the status light of the radio and LAN came back as red while the status light turned green (which I think this combination indicated that the OS is corrupted and no OS is present). I then connect my PC with a straight through cable to the LAN port and trying to telnet to the AP (which the default address should set back as 10.0.0.1/8) while I had my PC set to 10.0.0.20/8 with GW set to 10.0.0.20 as well. However, both ping and telnet to 10.0.0.1 came back failed. Can anyone share their experience or solution with me on how to resolve this issue ? Thanks.

6 REPLIES
kka
New Member

Re: Problem encountered in upgrading Cisco 1100s wireless access

You can't do updates in 12.3 via HTTP, the image is too big - always use TFTP.

The "image" is a tar archive so the correct command on the CLI is

archive download-sw tftp://server-ip/c1100-k9w7-tar.123-7.JA2.tar

This downloads the tar-archive and extracts the files into flash.

The actual IOS image will then be in a subdirectory:

flash:c1100-k9w7-mx.123-7.JA2/c1100-k9w7-mx.123-7.JA2

Resetting via the mode button only restores the default config.

But you can also load a tar file with a default name via TFTP:

- copy/rename the image on the TFTP-server to "c1100-k9w7-tar.default"

- power on the 1100 while holding the mode button

- wait until the middle LED on the ap turns red (30 seconds)

If everything works correctly, the ap downloads the tar archive

from the TFTP server and extracts it into the flash.

You could monitor this via serial console.

I've done this with several 1200 - works without problems.

New Member

Re: Problem encountered in upgrading Cisco 1100s wireless access

Hi kka,

Thanks for the response. Nonetheless at this point I think the biggest obstacle is to etablish a console or telnet connection to the failed access point. Given the fact that I may have erased some critical files before the upgrade (manually) in thinking that will free up some flash memory (guess I was too PIX or router oriented and thought this access-point works the same way). So right now even with the the reset there is no OS present on the AP (despite the successful copying of new OS to the AP from TFTP and I didn't use your command line the first time). So right now I have made numerous attempt to establish a connection using straight through and cross over cable from my PC (set up with a static address of 10.0.0.31/8) and I couldn't telnet or ping to 10.0.0.1 (supposedly the default address of the AP after the reset). So does this mean that there is pretty much nothing I can do other than RMA the unit?

kka
New Member

Re: Problem encountered in upgrading Cisco 1100s wireless access

Isn't there any output on the serial console (8N1 9600) during booting?

I would at least expect some output from the boot loader.

The idea was to load the default image per TFTP, by pressing

the mode-button during power on, until the middle LED turns red

after some 30 seconds. Then the ap will broadcast for a default

image:

process_config_recovery: set IP address and config to default 10.0.0.1

process_config_recovery: image recovery

image_recovery: Download default IOS tar image tftp://255.255.255.255/c1100-k9w7-tar.default

Unfortunately in your case there is a 5MB tar file from your "copy tftp flash"

command, so you won't be able to load another standard image in the 8MB flash.

One could try to assemble a smaller tar archive from an older (smaller) IOS version

by removing "unnecessary" files like the html subdirectory, but I guess it's

not worth the effort. (Expect problems from checksums, file size checks)

New Member

Re: Problem encountered in upgrading Cisco 1100s wireless access

This may sound like a dumb question and please forgive me if it is - How to you establish a console access to the AP ? (as they seem to have taken out the console port on the AP) Do you use the regular rollover cable (the ones for router and PIX) and plug into the LAN interface on the AP ? Or do we use the serial connector (for the PC's serial port) and connect with a straight through cable to the LAN interface of the AP ? Thanks.

kka
New Member

Re: Problem encountered in upgrading Cisco 1100s wireless access

No you are right, there is no serial console on the

1100. I was _assuming_ this would be the case, as is

on almost all other Cisco (WLAN) devices.

New Member

Re: Problem encountered in upgrading Cisco 1100s wireless access

Well I have pretty much tried everything I can think of to "revivie" this AP back to the "living". Nonetheless I must have deleted something that dictates its "conscious mind" and it is now in a "coma" for the hardware is fine but it wouldn't respond to any communication attempts (can't even establish a link). So I guess I just have to "pull the plug" and RMA it.

Anyhow.Thanks for sharing the knowledge. I appreciate your time.

368
Views
0
Helpful
6
Replies
CreatePlease to create content