Cisco Support Community
Community Member

Problems with DHCP and virtual PC connected to an AP in autonomous mode

I've a virtual machine (Windows 7) on my MacBook running on VMWare Fusion 6 running in bridge mode and can't get an IP address from my DHCP server. NAT mode in VMWare is working, but not an option.

I've tracked down the problem with Wireshark to the DHCP Offer that is dropped by the Cisco AP:

On the LAN side I've captured the packets and could see that the DHCP-DISCOVER from the Windows client was answered by the DHCP server with a DHCP-OFFER (all these packets are broadcasts in the same layer 2 network), but the OFFER was not forwarded by the 1142 AP running in autonomous mode, version 15.2(4)JA.

The problem looks to be similar to a previous discussion with WLCs where a solution is available meanwhile, see:

Is there any solution for APs running in autonomous mode?



Community Member

With a lot of testing, I

With a lot of testing, I found a solution: 

on the bvi interface an IP helper is required for virtual machines in bridged mode to receive an IP address from a DHCP server!

interface BVI1
 ip address dhcp client-id GigabitEthernet0
 ip helper-address x.x.x.x

It sounds a bit weird, because all devices are running in the same layer 2 network / broadcast domain and the AP as well as the wireless PC are configured for bridging, but it looks that the DHCP offers from the DHCP server are "eaten up" by the AP. With a DHCP relay agent (ip helper-address) on the AP you can fix the problem.


Community Member

Hi,Are you solved this issue?


Are you solved this issue? I have the same problem with my Aironet 2602 in autonomous mode, and I have IP Helper configured but this don't solved the problem for me. I have read in other post on this forum that it could be solved enabling passive client, but in autonomous AP I have not this option.



Community Member

It's already a while ago, but

It's already a while ago, but recently I got a new router at home and have upgraded the AP to 15.3(3)JAB as well. I'm not sure what the exact reason was, but the problem reappeared. I'm a Mac user and need the bridging mode at home for my home automation system that only comes with some windows tools. Therefore I spend some time to figure out more details and was able to solve the problem.

It turned out, that the AP needs to get an IP address by DHCP, otherwise the Windows machine never gets an IP address. I was able to see the DHCP discover broadcast from my virtual Windows PC as well as the DHCP offer from my home router. Even the packets from the DHCP relay agent (the AP with ip-helper) and the reply packet from the home router were shown with a DHCP debug on the AP and also with Wireshark on the LAN, but these broadcasts were not forwarded to wireless client. I've used Wireshark to capture packets on the WLAN adapter of my Macbook to verify that these packets were dropped on the AP and not on the Macbook with VMware Fusion. For some unknown reason the AP (acting as a bridge!) does not forward these broadcasts to the wireless client. 

After playing around it turned out, that it WORKS if the AP itself is configured as a DHCP client and does not have a static address AND there is a DHCP entry for my virtual Windows PC like this:

ip dhcp pool Macbook
 client-identifier 0100.5056.1234.56
 domain-name home.local

It's a bit weird that the AP itself needs to be a DHCP client and I can't explain why, but this setup works for me. I like to keep the DHCP server on my home router, so I've only added this DHCP reservation on the AP. 

I do agree with Jan, On the

I do agree with Jan, On the bvi interface an IP helper is required for virtual machines in bridged mode to receive an IP address from a DHCP server. It's working for me.

Community Member

thank you for response, I

thank you for response, I have configured ip helper address on BVI 1 and all interfaces, now work fine for native VLAN, but in no native VLAN it does not work for virtual machines.

In my previous post I have attached running-config file from AP.

CreatePlease to create content