Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems with WM6.0 Device on WCS/LW Access Points (SOLVED)

I just purchased an AT&T Tilt and hope to be able to use it in a wider audience at our company, however I am having a problem that may force me to return it and look for a different platform.

I can connect the Tilt to my home WiFi network (Open/WEP) without any problems, and I can connect to another "test" AP (autonomous AP1230) (Open/No-Encrypt) without any problems.

In my office (where it'll be used the most) we use Cisco's lightweight access points with the WCS controller system. This system is configured with Open authentication and no encryption, and has a captive portal that you must login to in order to gain access to the network.

When I connect to this network, I stay connected for about 30-45 seconds (I can ping the Tilt from my wireless laptop for about that long), and then the Tilt stops responding on the network. The WiFi status says that it is reassociating with the network, but it never does. I can manually tell it to connect to the network, but that fails, too. While this is occurring, I can see all of the SSIDs (not on the Cisco controller) that are available in our office, but cannot connect to any of those, either.

After a soft reset, I can connect to any of the other SSIDs with no problem until I try to connect to any of the SSIDs that are on the Cisco controller. After trying that, it repeats the same pattern and I must reset the Tilt before it will connect to any other access point.

I've actually done some wireless captures and cannot see any problems with the communication between the Cisco APs and the Tilt. It's just that after this "malfunction", the Tilt will successfully perform the normal 802.11 open-mode authentication, but will never proceed to the association phase.

The logs from the wireless controller don't reveal much other than seeing probe requests.

I've talked to AT&T and HTC, and they haven't been able to give me any good answers.

Has anyone had any similar experience with this or other devices? Since this seems to be isolated to the WCS-based system, I was hoping that there was a simple setting that we can change that may make the Tilt interoperable with the network.

Thanks!

2 REPLIES
New Member

Re: Problems with WM6.0 Device on WCS/LW Access Points (SOLVED)

It turns out that this problem was specific to Cisco's WLAN implementation. Cisco has a set of wireless extensions called CCX that are implemented on wireless devices (clients) to aid the infrastructure in managing the radio environment, location management, roaming, etc.

Apparently the WiFi chipset and/or drivers on the Tilt do not implement CCX (as 90% of other radios and drivers do), so when the WLAN sent a broadcast out asking for radio management reports, the Tilt's WiFi stack would just freak out.

We were able to work around this by disabling the CCX Location Measurement function in our Cisco 4400 series WLAN controller.

It would be nice to see an update from AT&T and HTC to fix this problem.

New Member

Re: Problems with WM6.0 Device on WCS/LW Access Points (SOLVED)

We're running into the issue as well with a lot of people at our help desk. As of right now it seems that neither HTC nor Cisco has addressed this problem yet.

265
Views
5
Helpful
2
Replies