Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Testing MobileIP and not sure if I will need a FA or not

I'm trying to get MobileIP working on a 2621 router. I've had some succes, but it doesn't work right just yet. I can get the MN to move from its home network into a foreign network just fine, but then the MN won't move back into its home network after leaving the foreign network until 10 min. later, which is unacceptable for what it will be used for. What it's going to be used for is to allow a MN to move through multiple subnets that will all be connected to the same router. However, if I issue the "clear ip route *" command, the MN immediately jumps back into its home network. The following is the configuration I'm currently using for testing.

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

memory-size iomem 10

ip subnet-zero

!

!

call rsvp-sync

!

!

interface Ethernet0/0

ip address 10.2.3.1 255.255.255.0

ip mobile arp

ip mobile foreign-service

ip mobile registration-lifetime 3

half-duplex

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface Ethernet0/1

ip address 10.2.4.1 255.255.255.0

ip mobile arp

ip mobile foreign-service

ip mobile registration-lifetime 3

half-duplex

!

router mobile

!

ip classless

ip http server

ip pim bidir-enable

ip mobile home-agent lifetime 3

ip mobile host 10.2.3.3 10.2.3.254 interface Ethernet0/0 lifetime 3

ip mobile host 10.2.4.3 10.2.4.254 interface Ethernet0/1 lifetime 3

!

!

dial-peer cor custom

!

!

line con 0

line aux 0

line vty 0 4

login

!

no scheduler allocate

end

Any help will be greatly appreciated. Thanks.

George

1 REPLY
New Member

Re: Testing MobileIP and not sure if I will need a FA or not

Proxy mobile IP feature works in conjunction with the Mobile IP feature in IOS. When you enable proxy mobile IP on your access point and on your wired network, the access point helps client devices from other networks remain connected to their home networks.Mobile IP provides users the freedom to roam beyond their home subnets while maintaining their home IP addresses. This enables transparent routing of IP datagrams to mobile users during their movement, so that data sessions can be initiated to them while they roam.

To enbale proxy mobile ip,the following links will be helpful to you:

http://www.cisco.com/en/US/products/hw/wireless/ps4570/products_installation_and_configuration_guide_chapter09186a0080101c31.html

To get some configuration guidelines about mobileip u can use the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t1/mobileip.htm

140
Views
0
Helpful
1
Replies
CreatePlease to create content