Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Troubles with a Workgroup Bridge associated to an AP 1100/1200 with VLAN su

Hello,

We want to interconnect the following equipment :

* an AP12xx configured as an workgroup bridge (WB), without VLAN's which is connected on the Ethernet port on a C3750 switch with all ports in access mode in the default VLAN 1 (so no VLAN's

on the remote client side).

* an Accesspoint (AP12** soft 12.3(2)JA2 or 12.3(4)JA) with a native VLAN 1 (= management LAN, without SSID) and a VLAN 20 with a client SSID. WLAN PC's can associate / work normally via this client SSID.

(campus network) <=> (AP12**) <=> (WB - AB12**) <=> (C3750) <=> (Client PC)

When the WB associates to this AP we see several strange things :

* on the C3750 switch port connected to the WB, we receive the next message despite the WB has no VLAN configuration :

%SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet1/0/1 VLAN1.

(We would expect that the WB sends only untagged Ethernet frames on his Ethernet port, because it has no vlan interfaces. Also, we suppose that the radio frames are untagged, otherwise normal client PC's couldn't communicate because they can't handle dot1q tags.)

* The client PC can ping the WB, and a PC in the campus network can ping the WB, but the PC can't access the campus network.

We tried to solve these problems by entering the mysterious command "workgroup-bridge client-vlan" on the WB, but we only receive the response "WGB Ethernet client VLAN enabled but no VLAN is defined".

We then tried to configure VLAN's on the WB, but we get only a lot more warnings (infrastructure-ssid only support on native vlan ,...)

Does anyone has any ideas how a Workgroup Bridge shoud be configured in this case ?

(Remark : This workgroup bridge in combination with a AP without VLAN configs on the AP, works fine).

Thanks in advance,

Philippe

2 REPLIES
Silver

Re: Troubles with a Workgroup Bridge associated to an AP 1100/12

Is trunking enabled on the switch port on which the wireless devices are connected to? This must be the problem. Enable trunking and ensure that the native VLAN on the Wireless devices match with the native VLAN on the Switch port to which the wireless devices are connected to.

New Member

Re: Troubles with a Workgroup Bridge associated to an AP 1100/12

We did also tests with a WGB with VLANs connected to a switchport in trunking mode, but this didn't work either. It seems that an infrastructure SSID can only be configured on a native VLAN, and in our case we want to assiociate to a VLAN20. Moreover, if this VLAN/trunk construction should work, we would also have a problem with the management address of the WGB because this must be in the native VLAN1 (int bvi1), which can't be accessed through VLAN20 (on the remote side the WGB can't route between VLAN 1 and 20)...

444
Views
0
Helpful
2
Replies