Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sam
Community Member

Unable to update 2106 bootloader

Greetings all! I'm having troubles updating my 2106 bootloader from 4.0.191.0 to anything more current. Attached is a log from an update attempt. Any suggestions would be greatly apprecaited!

Thanks in advance. -Sam

(Cisco Controller)

User: admin

Password:*****

(Cisco Controller) >show sysinfo

Manufacturer's Name.............................. Cisco Systems Inc.

Product Name..................................... Cisco Controller

Product Version.................................. 5.1.151.0

RTOS Version..................................... 5.1.151.0

Bootloader Version............................... 4.0.191.0

Build Type....................................... DATA + WPS

System Name...................................... WLC_2106

System Location..................................

System Contact...................................

System ObjectID.................................. 1.3.6.1.4.1.9.1.828

IP Address....................................... 192.168.3.2

System Up Time................................... 0 days 23 hrs 25 mins 38 secs

System Timezone Location.........................

Current Boot License Level.......................

Next Boot License Level..........................

Configured Country............................... US - United States

Operating Environment............................ Commercial (0 to 40 C)

Internal Temp Alarm Limits....................... 0 to 65 C

Internal Temperature............................. +55 C

--More-- or (q)uit

State of 802.11b Network......................... Enabled

State of 802.11a Network......................... Enabled

Number of WLANs.................................. 2

3rd Party Access Point Support................... Disabled

Number of Active Clients......................... 1

Burned-in MAC Address............................ 00:23:04:48:EE:40

(Cisco Controller) >transfer

(Cisco Controller) transfer>download serverip 192.168.3.112

(Cisco Controller) transfer>download path /

(Cisco Controller) transfer>download filename AIR-WLC2100-K9-4-1-185-0-ER.aes

(Cisco Controller) transfer>download start

Mode............................................. TFTP

Data Type........................................ Code

TFTP Server IP................................... 192.168.3.112

TFTP Packet Timeout.............................. 6

TFTP Max Retries................................. 10

TFTP Path........................................ /

TFTP Filename.................................... AIR-WLC2100-K9-4-1-185-0-ER.ae

s

This may take some time.

Are you sure you want to start? (y/N) y

TFTP Code transfer starting.

TFTP receive complete... extracting components.

TFTP File transfer is successful.

Reboot the switch for update to complete.

(Cisco Controller) >

(Cisco Controller) >reset system

The system has unsaved changes.

Would you like to save them now? (y/N) y

Configuration Saved!

System will now restart!

After reboot:

(Cisco Controller)

User: admin

Password:*****

(Cisco Controller) >show sysinfo

Manufacturer's Name.............................. Cisco Systems Inc.

Product Name..................................... Cisco Controller

Product Version.................................. 5.1.151.0

RTOS Version..................................... 5.1.151.0

Bootloader Version............................... 4.0.191.0

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Unable to update 2106 bootloader

HAHA..... that is a good question. Some of the ER files are not for the bootloader, but is an upgrade to "other stuff".... Again.... 4.2.112 is the latest bootloader but not for the 2106's.

-Scott
*** Please rate helpful posts ***
10 REPLIES
Silver

Re: Unable to update 2106 bootloader

What bootloader version are you trying to upgrade to? And is there a reason that you want to upgrade it? Normally the boodloader is upgraded at the same time as your firmware. The bootloader won't necessarily be the same version as your software.

sam
Community Member

Re: Unable to update 2106 bootloader

As shown in the example, I'm trying to go to:

AIR-WLC2100-K9-4-1-185-0-ER.aes, then 4.2.112.0-ER and ultimately to 5.0.148.0-ER to get the fix for CSCsd52483. I get the same results (no numbers changing on reboot) when I try to update using any of the above listed ER files.

Hall of Fame Super Silver

Re: Unable to update 2106 bootloader

The latest bootloader is 4.2.112.

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00805f381f.shtml

-Scott
*** Please rate helpful posts ***
sam
Community Member

Re: Unable to update 2106 bootloader

From http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00805f381f.shtml :

"Unlike previous ER images, a new bootloader file is not loaded when you install the 5.0.148.0 ER.aes file. This is true for all controllers. The 4.2.112.0 ER.aes file is the last ER file to contain a bootloader. If you want the latest bootloader, install the 4.2.112.0 ER.aes file. If you want to obtain the fix for CSCsd52483, also install the 5.0.148.0 ER.aes file.

The ER.aes files are independent from the controller software files. You can run any controller software file with any ER.aes file, but when you install the latest boot software file (5.0.148.0 ER.aes), it ensures that the boot software modifications in all of the previous and current boot software ER.aes files are installed."

I get the same results when trying to load 4.2.112.0-ER as well. On CCO, I see the following ER files listed for the 2106:

AIR-WLC2100-K9-4-1-185-0-ER.aes

AIR-WLC2100-K9-4-2-112-0-ER.aes

AIR-WLC2100-K9-5-0-148-0-ER.aes

AIR-WLC2100-K9-5-0-148-2-ER.aes

but I seem unable to get any of them to take.

-Sam

Hall of Fame Super Silver

Re: Unable to update 2106 bootloader

I think that is a cosmetic bug on the 2106. As long as the upload took on the wlc and you see it installing the firmware, you are good to go.

-Scott
*** Please rate helpful posts ***
sam
Community Member

Re: Unable to update 2106 bootloader

Excellent. Thanks for the clarification! Do you know if thats actually documented anywhere?

-Sam

Hall of Fame Super Silver

Re: Unable to update 2106 bootloader

I can try to see if I can find that.

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: Unable to update 2106 bootloader

Never mind.... the 2106 bootloader can't be upgraded:

When you install the 4.2.112.0 ER.aes file, a new bootloader file is also loaded. This is true for all controllers except the 2106 controller, for which the bootloader is not upgradable

Here is a link... just search for bootloader and it is the first one that appears.

http://www.cisco.com/en/US/docs/wireless/controller/release/notes/crn511510.html

-Scott
*** Please rate helpful posts ***
sam
Community Member

Re: Unable to update 2106 bootloader

Wow - thats goofy. If it can't be upgraded, then why the heck are there like a half a dozen 'ER' files on CCO for them? *sigh* Sometimes I don't get Cisco... :)

Thanks for all of your help!

-Sam

Hall of Fame Super Silver

Re: Unable to update 2106 bootloader

HAHA..... that is a good question. Some of the ER files are not for the bootloader, but is an upgrade to "other stuff".... Again.... 4.2.112 is the latest bootloader but not for the 2106's.

-Scott
*** Please rate helpful posts ***
470
Views
0
Helpful
10
Replies
CreatePlease to create content