Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unable to upgrade WLC on SRE to 7.4.121.0

Hi

 

I am unable to upgrade one of my WLC on SRE to 7.4.121.0.  I keep getting TFTP or FTP failure while storing in flash.  The WLC is currently running 7.2.110.0 and is running on a SRE 700 module in a 2951 router.

I have tried with both TFTP and FTP and I have redownloaded the file from Cisco.  I am using tftpd32 on Windows XP and it is allowed from the firewall.  When I perform the transfer it shows in the TFTPd32 log as successful.

 

Could someone please suggest how I can get this to work please?

I get this in the GUI message Log when I try the upgrade

 

*TransferTask: Apr 09 11:47:14.561: %OSAPI-6-FILE_DOES_NOT_EXIST: osapi_file.c:361 File : /mnt/images/vinitrd-secondary does not exist.(errno 2)
-Traceback:  086b7300 08048aad 08057585 086c7e19 09231700 09280c7e
*TransferTask: Apr 09 11:47:14.561: %OSAPI-6-FILE_DOES_NOT_EXIST: osapi_file.c:361 File : /mnt/images/vinitrd-primary does not exist.(errno 2)
-Traceback:  086b7300 08048a32 08057585 086c7e19 09231700 09280c7e
*TransferTask: Apr 09 11:47:10.513: %UPDATE-3-INIT_TLV_FAIL: installpkg.c:1773 Error -1 installing Temporal Logic Verifier (TLV). Failed to install downloaded s/w.
*TransferTask: Apr 09 11:47:10.513: %UPDATE-3-INCMPLT_WRITE: installpkg.c:752 Warning: Truncated write. Error writing chunk size 1270, len left = 1270, total len = 1270.

Thanks

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

that should be the right

that should be the right image for it. Can you reboot the WLC module and try again?

 

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
8 REPLIES

According to the release

According to the release notes, 7.4 is not supported on the SRE

 

http://www.cisco.com/c/en/us/td/docs/wireless/controller/release/notes/crn74.html#pgfId-1091515

 

HTH,

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

According to the release

According to the release notes for 7.4.121.0 it is

http://www.cisco.com/c/en/us/td/docs/wireless/controller/release/notes/crn74mr02.html#pgfId-1141671

Cisco Wireless Controller on Cisco Services-Ready Engine (SRE) (controllerM2) running on ISM 300, SM 700, SM 710, SM 900, and SM 910.

 

How do I determine the Controller M2 part

 

 

Hall of Fame Super Gold

I keep getting TFTP or FTP

I keep getting TFTP or FTP failure while storing in flash.

Can you explain this?  What is the EXACT error message?  What TFTP client are you using?  Cisco recommends using TFTPd32.  

New Member

When I perform the download

When I perform the download to controller using tftp the message I get is tftp error while storing in flash. 

I am using tftpd32 and the log from tftp32 shows the file copied properly. 

 

If I use FTP the message changes to FTP error while storing in flash. 

 

Hall of Fame Super Gold

Hmmm ... What is the filename

Hmmm ... 

What is the filename of the firmware you are using?

 

The firmware you are using could be corrupt.  Can you compare the MD5 hash value of your file versus the MD5 hash value found in the Cisco website?

New Member

I am trying to install AIR

I am trying to install AIR-WLC-SRE-K9-7-4-121-0.aes(7.4.121.0),

I have ran the md5 checker and they match.

that should be the right

that should be the right image for it. Can you reboot the WLC module and try again?

 

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

The reboot fixed it. Thanks

The reboot fixed it. Thanks to everyone for the help.

 

@Steve I tried to accept your reply as correct but keep getting an bad token error.

271
Views
0
Helpful
8
Replies
CreatePlease to create content