Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Updating IOS version on Lightweight Access point

Possibly a dumb question but I cannot find any documentation on Cisco's site.  What is the process for updating the IOS on a lightweight access point.  I have updated controllers and see that the "Primary Software Version" updates on the access points.  I wasn't sure if there is a seperate process to update the IOS image on the access points as well.

Thanks

~Tom

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Updating IOS version on Lightweight Access point

Ok, is there a documented process for updating this on the controllers then?

The IOS for the WAPs are "imbedded" in the firmware of the controllers.  You cannot run an IOS HIGHER then the controller.  The WLC provides the "version control" of the WAP.

Upgrade the firmware of the controller and the controller will verify if the WAPs are in the same IOS version if not, then the controller will upgrade/downgrade the IOS in the WAPs.

7 REPLIES
Hall of Fame Super Silver

Updating IOS version on Lightweight Access point

The LAP will obtain the code from the WLC.  So whatever codde the WLC boots on, the AP's will use.

-Scott
*** Please rate helpful posts ***
New Member

Updating IOS version on Lightweight Access point

Ok, is there a documented process for updating this on the controllers then? 

I see for example that an 1142 access point on my controller is running IOS version 12.4(23c)JA3.  Yet if I go to Cisco's download section I only see that release in the "IOS Software" section and not in the "Lightweight AP ISO Software" section.

Hall of Fame Super Gold

Updating IOS version on Lightweight Access point

Ok, is there a documented process for updating this on the controllers then?

The IOS for the WAPs are "imbedded" in the firmware of the controllers.  You cannot run an IOS HIGHER then the controller.  The WLC provides the "version control" of the WAP.

Upgrade the firmware of the controller and the controller will verify if the WAPs are in the same IOS version if not, then the controller will upgrade/downgrade the IOS in the WAPs.

Updating IOS version on Lightweight Access point

Ill add my 2 cents ..

IOS on Autonmous APs are based on AP firmware

CAPWAP on light APs are based on the WLC firmware

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
New Member

Updating IOS version on Lightweight Access point

Thanks everyone. I had not ran into this since I started this job but understand now. Thanks for your help.

Updating IOS version on Lightweight Access point

If you are new to Cisco WLCs stop by my blog www.my80211.com

I focus largley on Cisco Wireless...

Enjoy!

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________
New Member

I would like to move an  AIR

I would like to move an  AIR-LAP1142N-A-K9 which it is running IOS 12.4(23c)JA2 from an older 2500 WLC (7.0.116.0) to our 5508 WLC (7.4.121.0). I was reading the compatibility list and the AP is compatible but with IOS 15.2(2)JB3. When I move the AP to the 5508 WLC I know it will upgrade the Primary software but will it also upgrade the IOS?

5289
Views
0
Helpful
7
Replies