Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

WCS Heatmap Error

I've got over 90 APs installed and displayed on WCS but with one particular building, neither of the two floors will display heatmaps. Instead there is an error message that says "Error(s): You must correct the following error(s) before proceeding: Error: Some of the AP's RF Prediction is not yet computed. Please go to the AP placement page and place the APs properly, specify the correct antenna and then recompute the RF prediction." This is a new install so it hasn't yet worked.

I've done everything I can think of including deleting and recreating the building and its floors. I don't see anything in the bug toolkit or other postings or release notes. I even tried changing the antennas to "other" and then back again.

I'm running the latest WCS code 4.1.83 base+location and WLC code 4.1.171.

Anyone run into this and know how to correct it?

4 REPLIES
Cisco Employee

Re: WCS Heatmap Error

Hi,

If you try and run the RF prediction what happens?

If this also fails, make sure the floor has a calibration model. Maps>Click floor>Edit Floor Area (drop down box). Then run the RF prediction again.

Matt.

New Member

Re: WCS Heatmap Error

RF prediction: Same error

Calibration model: Cubicles - same error.

I reset the AP to factory configuration - same error.

I tried putting the AP on a functioning map for a different building but it ended up causing the same error on that map.

I'm wondering if perhaps the database for the AP has gotten corrupted somehow. But I wouldn't know how to fix it.

New Member

Re: WCS Heatmap Error

With continued testing I've found that if one of these conditions is done, I can display the heatmap for 802.11g:

1) disable 802.11a on the AP

2) use only the "other" antenna

So it seems to be an issue with the 802.11a antennas in WCS. Yet I'm using the same antenna on other APs. Strange.

Any ideas?

New Member

Re: WCS Heatmap Error

I thought I'd close this off with the solution I found.

I ended up deleting the APs from WCS and then letting them be discovered again. To do that I had to power them down. It took several minutes for WCS to recognize they were down and then a few minutes to no longer have the check box greyed out. You need the check box so you can select the AP and delete it. Then I powered up the APs. I put them on the map with default antenna settings to make sure the heatmap would show. Then I modified the antenna settings.

I think the WCS database somehow got corrupted when I originally added the APs for this building. The corruption was likely in the fields that define the 802.11a antenna type and orientation.

I hope this will be of help if and when others encounter this.

577
Views
0
Helpful
4
Replies
CreatePlease to create content