Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

WCS won't start/run - Health Monitor is already running

I am posting here my frustrations with running WCS in a Virtual Machine (VMWare) and just wanted to let everyone know what my issue was and what fixed it. WCS will complain when the memory is below 2.0 GB at the time of installation, but does not stipulate that this will cause it to not work, only that performance will be affected. Until my server arrives, I am forced to run WCS in a VM on a Windows XP desktop that has 3 GB of RAM. Not wanting to suck up too much RAM for the VM due to the fact that the workstation is used for other applications, I selected 1.0 GB of RAM. WCS installed and started the services fine. I pulled up the login page locally just to be sure. When I came back to work today, it was down. The wcs-0-0.log indicated everything was fine, but the apache_error.log showed this:

[Thu Apr 23 18:46:45 2009] [notice] Child 4064: Listening on port 443.

[Thu Apr 23 18:46:45 2009] [notice] Child 4064: Listening on port 80.

[Thu Apr 23 18:48:17 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.

[Thu Apr 23 18:48:17 2009] [notice] Child 4064: Exit event signaled. Child process is ending.

So you can see that it shut down after a couple of minutes. When I ran the WCSStatus link, it showed only that "Health monitor is already running." - that's all. So with that non-specific error, I was left to continue the struggle on my own. No current posts in the NetPro forum describe my issue, although bug CSCsx34113 was close:

Windows logout causes Apache process and WCS JVM to exit


When a user log outs of the physical console of a Win2K3 server, the Apache process and the WCS JVM exit.


This only affects Win2K3 servers, and only happens when logging out of the physical console. Logging out of a Remote Desktop does not cause the processes to exit


Do not log out of the physical console, if you must use it.

Use Remote Desktop.

Further Problem Description:


I decided to bump the RAM to 2.0 GB on the VM anyways, and restart the VM. BINGO! WCS is up and operational. Hope this helps...



Community Member

Re: WCS won't start/run - Health Monitor is already running

Hi Scott

I have exactly the same problem. The customer already gave the VM 3 GB memory, but we still have the problem, that the installation do not recognize 2 cpu's and 3 GB memory.

A question about the workaround. I only connect via a remote desktop; when I log out of the remote desktop, the server will shutdown also. For me it's not possible to stay logged in in the vm ware session, because it's not our server and we can't block the session. Is there any oder solution?

Do you still have the logout problem, even if you gave 2 GB memory?

Thanks in advance for your help.



Community Member

Re: WCS won't start/run - Health Monitor is already running

Dominic -

I must admit that I had other issues running WCS in this VM and it eventually got to a point where it would not start anymore. I have since wiped the computer it runs on, and installed Server 2003 and I now run WCS natively. As for the logout issue, the bug states that you should be able to manage it via RDP without incurring the shutdown on logout. There is an option to run VMs even after logging out, perhaps you should look into that? I would open a TAC case if you can, although I don't believe they support WCS in VMs currently.



Community Member

Re: WCS won't start/run - Health Monitor is already running

Hey Scott and Dominic, we had a similar problem here, but with Dameware. I opened a TAC case and was told there is a known issue with Dameware and WCS. I was told to only use RDP, VNC, etc. and that this would prevent the 'log out function' of Dameware from shutting down the WCS services.

Community Member

Re: WCS won't start/run - Health Monitor is already running

Hey all, I have also experienced issues with services shutting down when logging out of WCS on a Remote Desktop session to the WCS server. I have experienced this with every version of WCS I have installed from 4.2 up to 5.2.x. If I were to launch WCS in a browser on the server everything was fine until I closed the browser (a logout probaby does the same thing). I always used to check my upgrades to make sure everything worked ok and then when I logged off I couldn't run WCS remotely and would eventually have to restart the WCS server to resolve the issue.

With the code I just made sure NOT to launch WCS in a browser on the server. I performed my check remotely and avoided the whole issue.

For grins I just tested this by launching a browser on the WCS server and signing in and out of the application. It continued to run (never did in previous versions). It looks like perhaps this may have been resolved (at least for me) in the WCS code.

Community Member

Re: WCS won't start/run - Health Monitor is already running

Hi all

thanks a lot for the answers, but I think with the statement of Scott, we were able to solve the problem.

I used CoRD (remote desktop app) on a Mac to connect to the server and I didn't see, that the console checkbox for the connection was checked. Now I let the user logged in and the WCS works well.

I think that the problem is not already solved in the 5.2 version but I hope the next version (as the Bug Toolkit tells Fixed-In 5.2.136, actual it's only version 5.2.130) will have solved this issue.

But at the moment, the problem is "solved" for us.

Thanks and best regards


CrearPor favor para crear contenido