Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

Weird multiple AP1200 problem...

We have multiple buildings connected by AP1230B-A-K9's. Due to line of sight we are trying to relay through one building to another. Here's a schematic with nodes numbered for ease of discussion:

---Building A---

1: LAN


2: AP1230 as AP



---Building B---

3: AP1230 as WGB


hub or switch


4: AP1230 as AP



---Building C---

5: AP1230 as WGB


"AP1230 as AP" means an AP1230 in access point mode, usually with multiple clients associating to it. "AP1230 as WGB" means an AP1230 in workgroup bridge mode, to provide connectivity to the LAN (1) for a small local hardwired network. For clarity, the above "schematic" is just a subset of the whole network - for example, there are actually multiple buildings associating to node 2 in Building A.

The problem is that we cannot maintain connectivity between node 2 and node 5. When things are working properly, we have connectivity across the entire schematic shown above and throughput is excellent for an 802.11b system. But frequently, we'll lose connectivity. When this occurs, all associations remain intact. All devices report their RF links are up and stable.

Here's the really weird part: When the problem exists and we test with pings, either end of the above schematic can ping the first two nodes, but not all three. Example: Node 2 can ping nodes 3 and 4, but not node 5. From the other end, node 5 can ping nodes 4 and 3, but not node 2. The "middle" nodes, 3 and 4, can ping everyone in either direction (including beyond the above schematic). Only 2 and 5 cannot go farther than two hops away.

The baffling part is that provably working portions of the schematic OVERLAP. If node 2 can successfully ping node 4, and node 5 can successfully ping node 3, then we know for a fact that traffic is able to pass along the entire schematic. It just appears that traffic that originates from the "ends" cannot go more than two hops.

This problem appears and disappears at any time of day or night and lasts for random lengths of time. Sometimes things work properly for days or weeks before the problem occurs again. A couple of times rebooting node 2 has resolved it, but not always. Last night while the problem existed we performed a carrier busy test using node 4 and the moment the test was over, a continuous ping from node 2 to node 5 suddenly started working. That made us think it was a radio problem on node 4, but we've since tried resetting its radio and rebooting to no avail. The problem just seems to resolve itself when it feels like it.

We've tried various versions of AP1230 firmware but all behave identically. We've swapped out hardware at all nodes but all behave identically. We've tried different hardware (including non-Cisco) at node 5 but all behave identically. We started with an Ethernet switch in Building B between nodes 3 and 4 and moved to a simple Ethernet hub thinking it was a MAC table forwarding problem in the switch, but it made no difference.

Any assistance, ideas, questions, etc. will be greatly appreciated. Thanks!

CreatePlease to create content