Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

What version of WCS should I be running If I plan to upgrade my controllers

Per Cisco Security Advisory ID: cisco-sa-20090727-wlc there appears to a lot of security vulnerabilities. It is recommending that upgrade my controllers to 4.2.207.0 which I have no problems in doing.

Question: Would I also need to upgrade my WCS software (firmware) as well; seeing as though the controller software will be a much newer version?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: What version of WCS should I be running If I plan to upgrade

4.2.207.0 got released 4 days ago. There is actually no WCS version that was released after this, so there is no actual WCS version that will work 100% with this newer controller version.

If you must upgrade your controller to 4.2.207.0 you can do so, but you will loose managing ability from WCS until there is a new Maintenance Release of 4.2.x, 5.2.x or 6.0.x.

I suggest that you wait if the security advisory is not applicable to your environment.

6 REPLIES

Re: What version of WCS should I be running If I plan to upgrade

4.2.207.0 got released 4 days ago. There is actually no WCS version that was released after this, so there is no actual WCS version that will work 100% with this newer controller version.

If you must upgrade your controller to 4.2.207.0 you can do so, but you will loose managing ability from WCS until there is a new Maintenance Release of 4.2.x, 5.2.x or 6.0.x.

I suggest that you wait if the security advisory is not applicable to your environment.

Community Member

Re: What version of WCS should I be running If I plan to upgrade

Thanks so much Lucien for the quick turnaround and easy explanation. I will wait then.

thanks...

Jorge

Re: What version of WCS should I be running If I plan to upgrade

Actually, if you read the 4.2.207.0 release notes, you will see the following:

Note Only Cisco WCS 4.2.128.0, 5.2, and 6.0 support controllers running software release 4.2.207.0.

Community Member

Re: What version of WCS should I be running If I plan to upgrade

Hi Lucien.

In the Cisco security advisory ID: cisco-sa-20090727-wlc there is a matrix or a table that says "first fixed version" and "Recommended Release" For the First fixed version it is recommending 4.2.205 ane the recommended release it me to install 4.2.207.

This is a bit confusing for me. does this mean if I currently have version 4.2.205 installed on my WLC's I shouldn't have anything to worry about???

Re: What version of WCS should I be running If I plan to upgrade

I checked the bug listed on the advisory, you are fine with 4.2.205.0. Those bugs are fixed in that version you have.

I dont know why they have a different recommended version, probably to encourage users to upgrade for other bug fixes.

Community Member

Re: What version of WCS should I be running If I plan to upgrade

That's Great!!!

thanks for your help. This beats creating a tac case any day...

152
Views
0
Helpful
6
Replies
CreatePlease to create content