Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Wireless AP 1131 - upgrading to LWAP issues

Hi guys,

We're in the proces of upgrading our Wireless AP's from autonomus to LWAP. We're doing the upgrades remotely (we have 100's of sites to do, and it's not possible to be there to console on to each one), using a local computer to upgrade them to LWAP's with the Cisco Upgrade Tool.

Having some inconsistent bugs pop up though from time to time...

The most common one is that it basically buggers up the IP address after applying the recovery firmware image. It's supposed to keep the IP it had according to the IPFile.txt (for example 172.25.25.4), but it does something very weird... it keeps the last two octets (so 25.4 from the e.g) but replaces the first two octets with a 192.168 address. So the final address in this example after the UpgradeTool has done its work, is 192.168.25.4 - which is compeltely wrong.

This causes it to be unable to talk to the WLC (obviously, with bogus IP information it will struggle), and gives us big problems in that it wont ever come up unless someone can console to the AP and fix it. We can usually resolve the issue by munging about on the switch - switching the port it's connected to between access and trunk and doing some shut/noshut cycles seems to do the trick mostly.

Is there a way to stop this though?

Any help appreciated.

Greg

9 REPLIES
Hall of Fame Super Gold

Wireless AP 1131 - upgrading to LWAP issues

Try this then ...

1.   Use the command "archive download-sw tftp:///RCV_file.tar" to push the LWAP/CAPWAP/RCV file from the TFTP to a WAP of your choice.

2.   Erase the config of the WAP using the command "wr er".

3.  Reboot.

This will cause the WAP to load the RCV file and reboot with the same static IP address.

Another method of doing things is to create a DHCP scope and enable DHCP option 43 and point that to the Management IP address of your "landing" WLC.  You may also need to create a DNS entry too. 

New Member

Wireless AP 1131 - upgrading to LWAP issues

So are you saying this bug is an actual bug in the Cisco Upgrade Tool?

Dont forget, I dont have console to these AP's, so this is being done by telnet and my machine is not a TFTP server (except when running the Upgrade Tool!)

Hall of Fame Super Gold

Wireless AP 1131 - upgrading to LWAP issues

So are you saying this bug is an actual bug in the Cisco Upgrade Tool?

No I am not.  I have only used the Upgrade Tool when I'm converting 1230 WAPs.  Otherwise, it's easier for me to use the method I posted.

 so this is being done by telnet and my machine is not a TFTP server (except when running the Upgrade Tool!)

Can be done.  Get some other client to be the TFTP server is still OK.

New Member

Re: Wireless AP 1131 - upgrading to LWAP issues

Ok, thanks for the tip - will give this a try on the next upgrade I do - have a site with 5 AP's to do this morning so will attempt it with one of those!

I still think there is a bug either in the AP firmware or the Upgrade Tool itself. I dont see how else it could get the IP address so drastically wrong.

Cheers.

Hall of Fame Super Gold

Wireless AP 1131 - upgrading to LWAP issues

I still think there is a bug either in the AP firmware or the Upgrade Tool itself.

I'm not an authority to the Upgrade Tool because I haven't used this proggie since 2009.  Is this the latest version you're using?

New Member

Re: Wireless AP 1131 - upgrading to LWAP issues

yeah, we're using the latest version off the Cisco site - v3.4 which is the latest available.

New Member

Re: Wireless AP 1131 - upgrading to LWAP issues

Also, just thought I'd point out, we've already configured DHCP option 43 and added a static entry in our DNS servers to direct requests for CISCO-LWAPP-CONTROLLER to the WLC.

The problem gets caused by the AP's having invalid network configuration. And it only happend approx 50% of the time - sometimes the AP's come back up with correct network config and there is absolutely no pattern to it that I can see

Hall of Fame Super Gold

Wireless AP 1131 - upgrading to LWAP issues

Interesting.  I've never seen something like this before. 

Hall of Fame Super Gold

Wireless AP 1131 - upgrading to LWAP issues

Can you tell me what is the "RCV" firmware you are using?

980
Views
0
Helpful
9
Replies