Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Wireless clients can't get DHCP address from router behind Aironet 1100

We want our wireless clients to get their IP address assigned by the router on the network, not the AP.

We tried configuring the 1100 with a static IP address in the proper subnet, as well as setting it as DHCP so it would get its own address from the router. Both of these configurations work as far as the 1100 being seen on the network. However, wireless clients never get an IP address. The 1100 seems to not want to pass these DHCP requests through to the DHCP server on the router.

How can this be resolved?

4 REPLIES

Re: Wireless clients can't get DHCP address from router behind A

An 1100 will let DHCP pass to clients if everything is configured properly. Please post a Show Run from your AP, Switch & Router so we can take a look...

RA

New Member

Re: Wireless clients can't get DHCP address from router behind A

Two SSID and client can not receve ip from DHCP.

If I make VLAN (SSID) native, all OK!

How make work two SSID?

New Member

Re: Wireless clients can't get DHCP address from router behind A

OK. Here it is.

By the way, if I configure the wireless client with a proper static IP address, it will ping the 1100 but not beyond it.

Chelan6#show run

Building configuration...

Current configuration : 1420 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Chelan6

!

no logging console

enable secret xxx

!

ip subnet-zero

!

!

no aaa new-model

!

dot11 ssid CHELAN

vlan 1

authentication open

guest-mode

!

!

!

username Administrator privilege 15 password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid CHELAN

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

hold-queue 80 in

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address dhcp client-id FastEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

Chelan6#

New Member

Re: Wireless clients can't get DHCP address from router behind A

I guess this can be disregarded now.

After power-cycling everything, including the Catalyst switch that is feeding the 1100's, everything is working as it should.

Apparently, some settings on either the AP or the switch don't take effect until after a power-cycle. I suspect the packets were being dropped because of a VLAN setting mismatch.

678
Views
0
Helpful
4
Replies
CreatePlease to create content