Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Wireless Clients eventually not issued DHCP through WLC4404

Hi folks,

I have WCS 3.2.64, WLC4404 4.0.179.8, 1242 LWAPP APs, and a 2700 Location Appliance. I am running into an issue where the wireless clients (MS managed, mostly Cisco and Intel cards) stop recieving DHCP addresses. There are no errors being generated in any of the logs to indicate why the DHCP clients are not being issued IP addresses. Also, we are using IAS on Win2k3 as authentication server. The clients are logged as good logins. This all works fine for anywhere between 1 day and 1 week, then it all just stops passing DHCP addresses out. The same DHCP server is handing out addresses to wired clients as well, so the DHCP server appears ok. Many times I am only told about the problems much later and have a hard time nailing down the exact time it starts, so I am log-boy for a day reading the last couple of days worth trying to glean some kind of failure. Any ideas on how I can capture this when it happens and try to nail down what is causing it? Thanks in advance!

Cheers,

Brian Goodenough

7 REPLIES
Bronze

Re: Wireless Clients eventually not issued DHCP through WLC4404

Check for the VLAN on that port.

Check where is the helper command set.

Check DHCP Scope.

Try this link

http://www.cisco.com/en/US/products/hw/modules/ps2706/prod_module_installation_guide09186a00807084f9.html

Community Member

Re: Wireless Clients eventually not issued DHCP through WLC4404

Brian, I am glad to see this post. This has been driving us crazy, as we have seen this same issue. We have voice devices (7920/VOCERA) and when we have APs across 2 4404, our clients have had issues obtaining IPs as well. We are running IOS DHCP at the local site. Our fix is to locate all APs on one controller, and add any new APs to that controller. It works for a while, then 2-3 days, users start complaining and we have seen these clients probing for an IP. What is your status?

Community Member

Re: Wireless Clients eventually not issued DHCP through WLC4404

Check out this bug CSCse98623.

I-ve been impacted when applying the general template from WCS

Silver

Re: Wireless Clients eventually not issued DHCP through WLC4404

It is interesting that there are two more, additional, separate threads in the "General" conversation section regarding sporadic DHCP failure.

Has anyone opened a TAC case on this?

Community Member

Re: Wireless Clients eventually not issued DHCP through WLC4404

It's driving me crazy too... same thing is happening at one of my clients - with 2 new WiSMs in dedicated cat6504E switches, WCS & WiSMs on latest software. Win2k3 DHCP - no problem w/ DHCP for the wired clients; DHCP for wireless clients is sporadic at times. I've had 2 periods where none of the wireless clients clould get IP address at all. Rebooting the WiSMs gets things back to working, but that's not a viable long-term solution. TAC blames the DHCP server, despite Wireshark traces showing DHCP server responding properly to requests. For some unknown reason, the DHCP packets from the 2003 server are not getting back to the clients. I shifted over to using the DHCP service in the WiSMs as a possible workaround for a few days, but it's primitive, and I have to provide DHCP reservations for some special devices, which the WiSMs & 440x WLCs can't do.

Community Member

Re: Wireless Clients eventually not issued DHCP through WLC4404

I too am having this issue with the 4404. It seems that thing will work fine for a while then all of a sudden stop issuing DHCP. If i reset the trunks on the controller things start working again. Has anyone opened a TAC case about this issue?

Silver

Re: Wireless Clients eventually not issued DHCP through WLC4404

Hi Brian,

Please correct me if I am reading your post wrong. My initial take is that a WCS running 3.2 and a WLC running 4.0 might be a problem. I'd start by upgrading the WCS to 4.x and rule out any possible revision issues.

Also, note the licensing requirements in WCS 4.0.87 (Avoid 4.0.66 as it has numerous bugs):

NOTE:

Prior to downloading and installing the WCS 4.0 release software, please ensure that you have a WCS license file. Without this license file, you will not be able to add any new controllers to your WCS deployment and will receive daily warnings about having an unlicensed copy of WCS.

Hope this helps.

581
Views
11
Helpful
7
Replies
CreatePlease to create content