Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

wireless hosts issue

I have a Cisco 851 configured to support both wireless and wire networks with different dhcp pools. Router is configured with irb and on bridge group 1

Wireless network = 192.168.1.0

Wired network 192.168.0.0

--------

Problem

=======

Hosts A = 192.168.0.17 is the media server with shared files..ready for hosts B = 192.168.1.35 to grab. Hosts B is a Sony PS3 game console. Hosts A can ping hosts B, and i can ping hosts B with the BVI1 interface for the Dotradio0.1....

Hosts B uses port 1900 (SSDP - unicast/multicast...

If i try to connect to the media server, i get error message, and the media server is learning the mac address of the sony system.

I think "bridge-group 1 block-unknown-source" on the dotradio0.1 is blocking the traffic for 1900 but i cannot remove it since its and irb statement. Naing the sony, it doesn't show up in the router.

Help.

-----------

bridge irb

!

interface Dot11Radio0.1

description open keymaster

encapsulation dot1Q 1 native

ip broadcast-address 192.168.1.255

ip helper-address 192.168.1.17

ip helper-address 192.168.1.255

no ip redirects

ip local-proxy-arp

no ip route-cache

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface BVI1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip mroute-cache

!

ip forward-protocol nd

ip forward-protocol udp 1900

ip route 0.0.0.0 0.0.0.0 FastEthernet4

Interface IP-Address OK? Method Status Protocol

Dot11Radio0 unassigned YES NVRAM up up

Dot11Radio0.1 unassigned YES unset up up

FastEthernet0 unassigned YES unset up up

FastEthernet1 unassigned YES unset up up

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up down

FastEthernet4 .... YES DHCP up up

Vlan1 192.168.0.1 YES NVRAM up up

NVI0 unassigned YES unset administratively down down

BVI1 192.168.1.1 YES NVRAM up up

4 REPLIES
Silver

Re: wireless hosts issue

Haha, this must be a home network of some kind. Trying to get a PS3 to access a media server is rarely a business issue ;)

What strikes me as odd is that the media server is learning the MAC address of the PS3. MAC addresses should never leave a subnet, so it sounds like we have a routing problem.

Can you post your entire config? Also post a "show ip route". It looks like VLAN 1 is the 192.168.0.0 subnet, but BVI1 is the 192.168.1.0 subnet. I believe that you might have BVI1 configured to map to VLAN 1, which would effectively combine the subnets. It should still pass traffic (and indeed it does by the ping test), but it might be causing your clients some grief.

Out of curiosity, do you have another AP that you could use to connect your PS3? Even if it's just a LinkSys or something, it'd be good to ensure that the wireless router is indeed the problem.

New Member

Re: wireless hosts issue

Yes, vlan1 and bvi1 are both mapped with irb - bridge group 1

===============

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

24.0.0.0/22 is subnetted, 1 subnets

C 24.163.36.0 is directly connected, FastEthernet4

10.0.0.0/32 is subnetted, 1 subnets

S 10.127.32.1 [254/0] via 24.163.36.1, FastEthernet4

C 192.168.0.0/24 is directly connected, Vlan1

C 192.168.1.0/24 is directly connected, BVI1

S* 0.0.0.0/0 is directly connected, FastEthernet4

GateKeeper#

===============

!

ip dhcp pool HOSTPOOL

import all

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

!

ip dhcp pool WIRELESS

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

!

ip cef

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

no ip domain lookup

archive

log config

hidekeys

!

!

ip ssh version 2

!

bridge irb

bridge mac-address-table limit 300

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

description ROADRUNNER

ip dhcp client update dns server both

ip address dhcp

no ip proxy-arp

ip nat outside

ip virtual-reassembly

no ip mroute-cache

duplex auto

speed auto

no cdp enable

!

interface Dot11Radio0

description KeyMaster

no ip address

no ip route-cache cef

no ip route-cache

!

ssid KeyMaster

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

packet retries 20

channel least-congested 2437 2442 2447 2452 2457 2462

station-role root access-point

world-mode legacy

!

interface Dot11Radio0.1

description open keymaster

encapsulation dot1Q 1 native

no ip redirects

ip local-proxy-arp

no ip route-cache

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

ip address 192.168.0.1 255.255.255.0

ip nat inside

no ip virtual-reassembly

!

interface BVI1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip mroute-cache

!

ip forward-protocol nd

ip forward-protocol udp 1900

ip route 0.0.0.0 0.0.0.0 FastEthernet4

!

New Member

Re: wireless hosts issue

I do not have another AP..

I also want to add that the PS3 can get out to the internet, the media server can ping the PS3 when on the Wire network(but cannot when on the wireless)

And that the main problem is for the PS3 to be able to access shared files on the media server...any help will be appreciated.

Silver

Re: wireless hosts issue

I see that you have NAT configured on both your BVI and VLAN 1 interfaces. NAT should only be configured on your Fa4 interface for routing out to the Internet. You shouldn't need NAT for routing traffic internally.

Can your PS3 connect to anything else on the wired network when on the wireless interface? Can any other wireless client connect to the wired network while on the wireless?

222
Views
0
Helpful
4
Replies
CreatePlease to create content