Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

wireless web page redirect not woking

Hi all

wireless web page redirect not woking 

software version : 4.2.207.0

one of the ssid on the controller has web authentication and the authentication page not showing once connected .

some clients  ( like  laptop) authentication page shows but when we press submit button nothing happen .

Please help

8 REPLIES
Hall of Fame Super Silver

Re: wireless web page redirect not woking

Wow that is old code. The only thing that prevents a WebAuth page from displaying is DNS. If you have a splash page that shows up but doesn't do anything after you hit submit, then you probably need to reboot your WLC. This is assuming that it has been working for a while.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

wireless web page redirect not woking

Hi

Thanks for your reply .

There are other ssid alos having web authentication , but the problem with only two ssids . and i have rebooted couple of times . I dont think its an html code issue , we use the cisco default

Thanks

Hall of Fame Super Silver

Re: wireless web page redirect not woking

A reboot should if fixed it. Have you gone through the troubleshooting guide? Remove the WebAuth from the SSID's and test to see if users connect and can surf the internet. If not? Then you need to fix DNS. If you have multiple SSIDs using webauth and some are working and some are not, then either it's DNS related or your WLC is going bad. You can try to set the WebAuth to customize and hit apply and then back to the Cisco internal default and see if that helps.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: wireless web page redirect not woking

Hi

Tnx again , i beleive i have narrow down the problem , After physically removed the controller from the switch problem experencing only with mobile devices .In your previous reply you mentioned abt DNS .  I  did not understand the role of DNS in it. sorry for that . Once user connected SSID and browse anything , this will redirect to the virtual ip http://1.1.1.1/login.html?........ .we have not registered this virtual ip in the DNS server .

Please help

VIP Purple

Re: wireless web page redirect not woking

check the html file again.(There could be issue with html code.)

I attached the login file try with this and test it again.

And also update the WLC software to 7.x version

Reagrds

Hall of Fame Super Silver

Re: wireless web page redirect not woking

Here is a reference guide for troubleshooting WebAuth

http://www.cisco.com/en/US/products/ps10315/products_tech_note09186a0080a38c11.shtml

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
New Member

Re: wireless web page redirect not woking

Hi

I beleive i figured out the problem ,

I open the interfaces , edit the affected interface and click apply button , that moment it worked 

After some time again it stopped working

Please help

Hall of Fame Super Silver

Re: wireless web page redirect not woking

Can you explain what you mean by open the interfaces?  You don't have to have an A record in DNS for your VIP unless your using a 3rd party certificate.  Is the problem that users are no being presented with the splash page?  I would really look at upgrading also... If you have a 4400, then the latest v7.0.x is the code to be on.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
344
Views
0
Helpful
8
Replies
CreatePlease to create content