Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

WISM Controller DHCP&Console Problem

Hi,

I have two WISM controllers on different 6500 chassis, I am having the same problem on both.

The WISM does not initiate DHCP requests for the service port, this has been confirmed by running DHCP debugs on the Supervisor engine. To make things more complex, when I connect to console port and reset the module, I see nothing on screen, though I am using 9600-8-N-1 console settings, I have also tried different applications to connect, Hyperterminal, Putty, SecureCrt, all show the same symptom.

I tried to move the modules to different slots, same problem. My configurations are shown below, I can confirm that a client can take an IP address from the wism service DHCP pool.

I have read several discussions where the DHCP service was disabled on the WISM factory settings for some reason, but in my case, seems the console is also disabled!

I also suspected a bug about sanity of DHCP and WISM in "SXI" IOS, so I tried different versions of SJ realeses, always getting the same problem. When the controllers boot up, the status led turns off, which is normal.

Dist1-Sw1#sh module 3

Mod Ports Card Type                              Model              Serial No.

--- ----- -------------------------------------- ------------------ -----------

  3   10  WiSM WLAN Service Module               WS-SVC-WISM-1-K9   SAL1441W75Q

Mod MAC addresses                       Hw    Fw           Sw           Status

--- ---------------------------------- ------ ------------ ------------ -------

  3  f866.f29a.4268 to f866.f29a.4277   2.4   12.2(14r)S5  12.2(33)SXI9 Ok

Mod  Sub-Module                  Model              Serial       Hw     Status

---- --------------------------- ------------------ ----------- ------- -------

  3  Centralized Forwarding Card WS-SVC-WISM-1-K9-D SAL1439UHAK  2.2    Ok

Mod  Online Diag Status

---- -------------------

  3  Pass

Dist1-Sw1#sh vlan | include 910

910  WISM-Service                     active    Gi3/9, Gi3/10, Gi6/48

interface Vlan910

ip address 172.19.19.3 255.255.255.0

end

ip dhcp excluded-address 172.19.19.1 172.19.19.4

!        

ip dhcp pool WISM-Service

   network 172.19.19.0 255.255.255.0

   default-router 172.19.19.3

wism service-vlan 910

wism module 3 controller 1 allowed-vlan 9

wism module 3 controller 2 allowed-vlan 9

wism module 3 controller 1 native-vlan 9

wism module 3 controller 2 native-vlan 9

Dist1-Sw1#sh wism status

Service Vlan : 910, Service IP Subnet : 172.19.19.3/255.255.255.0

      WLAN

Slot  Controller  Service IP       Management IP    SW Version  Status

----+-----------+----------------+----------------+-----------+---------------

3     1           0.0.0.0          0.0.0.0                      Service Port Up

3     2           0.0.0.0          0.0.0.0                      Service Port Up

Dist1-Sw1#sh interfaces status module 3

Port         Name               Status       Vlan       Duplex  Speed Type

Gi3/1                           connected    trunk        full   1000 WiSM

Gi3/2                           connected    trunk        full   1000 WiSM

Gi3/3                           connected    trunk        full   1000 WiSM

Gi3/4                           connected    trunk        full   1000 WiSM

Gi3/5                           connected    trunk        full   1000 WiSM

Gi3/6                           connected    trunk        full   1000 WiSM

Gi3/7                           connected    trunk        full   1000 WiSM

Gi3/8                           connected    trunk        full   1000 WiSM

Gi3/9                           connected    910          full   1000 WiSM

Gi3/10                          connected    910          full   1000 WiSM

Dist1-Sw1#sh wism module 3 controller 1 status

WiSM Controller 1 in Slot 3 configured with auto-lag

Operational Status of the Controller : Service Port Up

Service VLAN                         : 910

Service Port                         : 9

Service Port Mac Address             : 68ef.bd2f.64e2

Service IP Address                   : 0.0.0.0

Management IP Address                : 0.0.0.0

Software Version                     :

Port Channel Number                  : 405

Allowed-vlan list                    : 9

Native VLAN ID                       : 9

WCP Keep Alive Missed                : 0

Dist1-Sw1#

Dist1-Sw1#sh wism module 3 controller 2 status

WiSM Controller 2 in Slot 3 configured with auto-lag

Operational Status of the Controller : Service Port Up

Service VLAN                         : 910

Service Port                         : 10

Service Port Mac Address             : 68ef.bd31.5862

Service IP Address                   : 0.0.0.0

Management IP Address                : 0.0.0.0

Software Version                     :

Port Channel Number                  : 406

Allowed-vlan list                    : 9

Native VLAN ID                       : 9

WCP Keep Alive Missed                : 0

Dist1-Sw1#

6 REPLIES

WISM Controller DHCP&Console Problem

Can you do a show vlan summary? 

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

WISM Controller DHCP&Console Problem

Hi Steve,

The vlan is active (L2 and L3)

Dist1-Sw1#sh vlan | include 910

910  WISM-Service                     active    Gi3/9, Gi3/10, Gi6/48

Thanks,

Jawad

WISM Controller DHCP&Console Problem

Jawad,

     If you can, unseat the WiSM, you should see a grey ribbon cable IIRC, going from teh back to the front near where the console port is.  make sure this is seated properly.  It wont' fix the DHCP issue, but if it's loose it would explain why the frontedge isn't working.

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

WISM Controller DHCP&Console Problem

There is absolutely no ribbon IIRC at the back or any where on WISM module, is it supposed to be there?

Thanks,

Jawad

WISM Controller DHCP&Console Problem

I was pulling that from memory, so I might not be recalling it correctly.  But if you are 9600/none/8/1 you should see something when it boots, but nto able to interract unless flowcontrol is none.

Might be a good time to call TAC and RMA.

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

WISM Controller DHCP&Console Problem

Flow control is absolutely disabled in all of my endless attempts to connect to it.

What is weird is that I am facing this on two WISM modules, both ordered and shipped together at the same time, what a coincidence !

Jawad

584
Views
0
Helpful
6
Replies
CreatePlease to create content