Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WLC 4402 LAG connection to 2 different chassis of 6509 VSS switch system

Hi,

I have inherited a 6509 VSS switch system as the network core and have the task of ensuring proper redundancy and redesign of the directly connected data center devices.  One of the connected devices (WLC 4402) physically appears to be connected to both switches - the WLC is in the same rack as VSS-Chassis1 so I can trace the fiber from WLC port 1 to gi1/1/22, the other fiber from the WLC port 2 goes into the floor and presumably over to VSS-Chassis2 gi2/1/22 (there is fiber connected there, I have link lights on both sides, and the port channel, Po200, on the VSS switch which is configured on gi1/1/22 is also configured on gi2/1/22).  My question pertains to the CDP neighbor output I get on the VSS switch: (truncated to include just the WLC)

...

NCMECHQWiFi1     Gig 1/1/22        137               H    AIR-WLC44 Gig 0/0/2

NCMECHQWiFi1     Gig 1/1/22        137               H    AIR-WLC44 LAGInterface0/3/1

NCMECHQWiFi1     Gig 1/1/22        137               H    AIR-WLC44 Gig 0/0/1

It looks like both WLC ports are physically connected to Gi1/1/22, which they are quite obviously not.

This is confirmed on the WLC's sho cdp entry all output:

(Cisco Controller) >show cdp entry all

-------------------------

Device ID: ncmec-vsscoresw1.ncmec.org

Entry address(es): 100.1.0.254

Platform: cisco WS-C6509-E,  Capabilities: Router Switch IGMP

Interface: LAGInterface0/3/1,  Port ID (outgoing port): GigabitEthernet1/1/22

Holdtime : 160 sec

I believe that the multi chassis etherchannel is set up correctly on the VSS:

vsscoresw1#sho run int gi1/1/22             

!

interface GigabitEthernet1/1/22

description WLC-Management

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 200 mode on

end

vsscoresw1#sho run int gi2/1/22

!

interface GigabitEthernet2/1/22

description WLC-Management

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 200 mode on

end

vsscoresw1#sho run int po200

!

interface Port-channel200

description WLC-Management

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

end

And yet when I show the details of port channel 200, I expect to see "mode on" but get instead see LACP which is unsupported on the WLC:

vsscoresw1#sho etherchannel 200 detail

Group state = L2

Ports: 2   Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol:    -

Minimum Links: 0

                Ports in the group:

                -------------------

Port: Gi1/1/22

------------

Port state    = Up Mstr In-Bndl

Channel group = 200         Mode = On      Gcchange = -

Port-channel  = Po200       GC   =   -         Pseudo port-channel = Po200

Port index    = 0           Load = 0xFF        Protocol =    -

Mode = LACP

Age of the port in the current state: 180d:19h:47m:01s

Port: Gi2/1/22

------------

Port state    = Up Mstr In-Bndl

Channel group = 200         Mode = On      Gcchange = -

Port-channel  = Po200       GC   =   -         Pseudo port-channel = Po200

Port index    = 1           Load = 0xFF        Protocol =    -

Mode = LACP

Age of the port in the current state: 180d:19h:47m:02s

                Port-channels in the group:

               ----------------------

Port-channel: Po200

------------

Age of the Port-channel   = 354d:12h:47m:27s

Logical slot/port   = 46/19          Number of ports = 2

GC                  = 0x00000000      HotStandBy port = null

Port state          = Port-channel Ag-Inuse

Protocol            =    -

Fast-switchover     = disabled

Load share deferral = disabled  

Ports in the Port-channel:

Index   Load      Port          EC state       No of bits

------+------+------------+------------------+-----------

0      FF       Gi1/1/22                 On   8

1      FF       Gi2/1/22                 On   8

Time since last port bundled:    173d:17h:06m:34s    Gi2/1/22

Time since last port Un-bundled: 173d:17h:06m:34s    Gi2/1/22

Last applied Hash Distribution Algorithm: Fixed

>>>  So my question, arising at least partly from the apparently misleading CDP information, is this:  How can I confirm that the WLC is correctly dual homed to both core switches? (short of tracing the cable)  I ask because there are several other devices (not WLCs) that need to have the dual homed connections confirmed.

I tried a layer 2 trace route but for all macs associated with the WLC, the trace abborts with the error "Device has Multiple CDP neighbours on destination port."

Thanks in advance!

Sue

Everyone's tags (5)
2 REPLIES
New Member

WLC 4402 LAG connection to 2 different chassis of 6509 VSS switc

PS:  It is critical that I confirm the redundancy, since as a part of the data center redesign we will be moving the second VSS chassis to the same rack with the first to simplify the dual connections.  I need to verify all the redundant connections before I take it offline and move it.  Thanks!

WLC 4402 LAG connection to 2 different chassis of 6509 VSS switc

Tracing the cable would be the best as you can then physically verify everything.

But you could always shut one of the ports in the port channel down and see if the corresponding port on the WLC goes off as well. 

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
1713
Views
0
Helpful
2
Replies
CreatePlease login to create content