Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

WLC 5508 HA RMA Process

Hi all,

I am currently in a situation where our primary 5508 failed, our secondary 5508 took over, and we RMA'd the primary. Now that I have received the primary RMA device, I am stuck with what to do with it. I know that I need to transfer the licensing and have found documentation on that but what does the rest of the process look like? Do I just plug it back in using the redundancy port and away we go? I assume there are additional steps but I am having trouble finding documentation on it. Please help! Thanks in advance,

Derek

Everyone's tags (3)
9 REPLIES
Hall of Fame Super Gold

Re: WLC 5508 HA RMA Process

I presume you are not running HA SSO.

So if this is the case ...

Your old Primary and your current Secondary probably have the same configuration and the only difference between the two are the IP addresses.

So what you do is go to the Secondary and copy the configuration to a client where you can "massage" the file.   Open the file and change the IP addresses.

Configure the replacement unit for reachability, upgrade the firmware to be the same level as the Secondary WLC and copy the file across.

Normally, for a 5508, I always use the Service Port to upload the config because I don't have to be scampering around looking for an GLC-T.  I just give the Service Port a /30 address and assign my laptop with the 2nd IP address.

Scott has mentioned before that the login credentials need to be changed and I don't seem to remember where his posts are.  Give it a few hours and when he wakes up he should be able to add some more details.

Community Member

WLC 5508 HA RMA Process

Thanks for the reply. To be honest, I do not know if we are running HA SSO or not. Is that tied to the version we are running? This is actually for a client of ours and I have never had to do an RMA in a HA environment. I am picking up the info as I go This is definitely helpful. I am hoping to give good enough instructions to the customer so I do not have to go out there and do it, as its 3 hours away. Thanks again, hope to hear more about the part you weren't sure about.

Community Member

WLC 5508 HA RMA Process

I recently discovered that this 5508 setup is running HA SSO (It's 7.3 code). Does this mean the process has changed?

Hall of Fame Super Silver

Re: WLC 5508 HA RMA Process

You need to configure the new WLC and also make adjustments to the HA wlc. Hopefully you had a backup of the WLC configuration or else you will have to rebuild it. Also, WebAuth bundles and certificates needs to be uploaded to the WLC also. The recommended HA code version is v7.4.110.0 MR1. The backup WLC will not push the configuration to the primary.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***

Re: WLC 5508 HA RMA Process

I do agree with Scott.

Community Member

I am in this situation - sort

I am in this situation - sort of!

I have two HA pairs of 5508 that I am swapping over due to wanting the licenses swapped and Cisco refused to accomodate us by other means :/

i.e. I have A-B HA pair and C-D HA pair but I want A and C to swap locations, and B and D to swap locations.

AB have base 50 AP license, CD have base 100 AP license (I want the 100 license in AB locations, without messing with the AB config)

AB and CD are in a mobility group to add to the mess :p

All 4 are 5508s, B and D have HK SKU.

Both HA sets are running SSO and 7.6.130

I am doing the primary first of each but encountered the issue that the config backup does not contain any redundancy configuration! :( 

 

Hall of Fame Super Silver

You have to fail over to the

You have to fail over to the HA controllers and pull out the primary. Then you have to take the primary off line and factory reset them and then set them up for the basic ap SSO configurstion.  See this link in replacing WLC in SSO.

when in AP SSO, the configurstion backup is only from the active box.

http://www.cisco.com/c/en/us/support/docs/interfaces-modules/wireless-services-module-2-wism2/117729-configure-wlan-00.html#anc7

-Scott

-Scott
*** Please rate helpful posts ***
Community Member

Thanks Scott. After a few

Thanks Scott. After a few mishaps I figured that this basic config involves:

- Recover-config and reboot

- Enter the correct management address, subnet, VLAN tag, LAG parameters as the former primary unit and the rest can be garbage? -> reboot

- Login and enter:

      config interface address redundancy-management IP1 peer-redundancy-management IP2
 config redundancy unit primary
      config redundancy mode sso         (doesn't seem to be sso AP option in this version - 7.6.130)
 
- Reboot and either power off or wait for boot then power off
- Connect up heartbeat and management cables and power on
- Wait for sync...
 
 
however I experienced an issue where it got to "Found the Peer. Starting Role Determination..." and then would get no further after waiting 15minutes.
 
Should this be a fairly quick step? I then rolled back and put my old primary in the same way and ended up waiting about 30mins and finally it worked. I realised after the fact that when I put the new primary in I hadn't set the LAG correctly and I also did not give it the exact same management address so that might have caused trouble earlier, but I can't explain why the old primary took so long either.

 

Community Member

Ok I followed the above

Ok I followed the above procedure exactly this time and it worked just fine.

 

The only remaining question is around mobility macs: my A&B HA pair is in a mobility group with C&D. It's not 2-way.. the WLANs from C&D are available anchored on A&B but not the WLAN from A&B at C&D.

 

The config on A&B has 2 mobility members:

itself with management IP and A's burnt-in MAC as it's mobility mac

C&D with C&D's management IP, and C's burnt-in MAC

 

Now that I've removed WLC A, taken it to site C, removed WLC C, put in WLC A and synched with D, it has retained the same mobility MAC.

At the moment it's still running Active on the secondary unit (D) and I'm worried that when I fail back to C(ex-A) it might cause issues with the mobility. 

854
Views
5
Helpful
9
Replies
CreatePlease to create content