Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WLC 5508 to C6509 etherchannel problem

I have configured a 6509 with a port-channel over 2 interfaces as the ap-manager interface for a 5508 WLC, see below. I am not able to ping the WLC ap-manager interface from the 6509 console port. The WLC ap-manager interface is on the vlan101 subnet and uses vlan tags.

interface Port-channel9

description ether channel for WLC 1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 101

switchport trunk allowed vlan 101,113,127

switchport mode trunk

logging event link-status

logging event bundle-status

!

interface GigabitEthernet7/2

description ether channel for WLC 1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 101

switchport trunk allowed vlan 101,113,127

switchport mode trunk

logging event link-status

logging event bundle-status

channel-group 9 mode on

!

interface GigabitEthernet8/2
description ether channel for WLC 1
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 101
switchport trunk allowed vlan 101,113,127
switchport mode trunk
logging event link-status
logging event bundle-status
channel-group 9 mode on
!

port-channel load-balance src-dst-ip

and the 5508 is using:
Version: 6.0.199.4

I found in the manual (Cisco Wireless LAN Controller Configuration Guide, Software Release 7.0 June 2010,) to try using :

port-channel load-balance src-dst-ip exclude vlan

but the 6509 won't take it. Any ideas?

  • Other Wireless - Mobility Subjects
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: WLC 5508 to C6509 etherchannel problem

Can you provide the interface configs of the WLC?

You are saying you tag the AP-Managers as vlan 101?

But you have your switch set for Native vlan 101 (so it won't tag the traffic)......   end result of a Management Interface like this is typically "it doesn't work".

Is your Management interface an AP-MGR? or you have Management + 2 AP-MGRs?

16 REPLIES
New Member

WLC 5508 to C6509 etherchannel problem

I meant to add that the 6509 is using:

(s72033_rp-ADVIPSERVICESK9_WAN-VM), Version 12.2(33)SXI6, RELEASE SOFTWARE (fc4)

Silver

Re: WLC 5508 to C6509 etherchannel problem

Can you provide the interface configs of the WLC?

You are saying you tag the AP-Managers as vlan 101?

But you have your switch set for Native vlan 101 (so it won't tag the traffic)......   end result of a Management Interface like this is typically "it doesn't work".

Is your Management interface an AP-MGR? or you have Management + 2 AP-MGRs?

New Member

Re: WLC 5508 to C6509 etherchannel problem

I cannot get the interface configs for the WLC for a few days, I had to go out of town. I will try removing the Native Vlan statement from the port channel and 2 interfaces.

Yes, Management is the AP-MGR, not management plus 2 AP-MGRs

Mike Fleck

Datanamics, Inc

cell 702-985-5420

New Member

WLC 5508 to C6509 etherchannel problem

I remoted into the switch and removed the Native Vlan and now everything is fine, Thanks "weterry"

Silver

WLC 5508 to C6509 etherchannel problem

Fantastic. Very common problem (typically manifests as "I can't manage the WLC").  If you wanted to leave the switch as native vlan 101, then you'd want to set "0" as the vlan on the interface (so the wlc doesn't tag it, and switch knows to put it in 101).

The issue with this latter approach is that I don't think you can trust COS for untagged traffic, so QOS would be a problem to get working.

New Member

WLC 5508 to C6509 etherchannel problem

Hello. I think that is a well-known problem. You cannot set the native vlan on the wlc. It's alway vlan 1. After removing the setting "switchport trunk native vlan 101" the native vlan change to default which is vlan number 1.

I am using software version 6.0.199.4, too.

Re: WLC 5508 to C6509 etherchannel problem

thats not true. You can tag all the interfaces on the WLC, so long as you remember it's a dot1q trunk. So you would want the native VLAN on the switch to be something other than what any interface on the WLC is. Otherwise the switch will drop the traffic that is tagged on the native VLAN.

So in the above scenario setting the switch poet native VLAN to 999 would work so long as VLAN 999 is not used on the WLC.

Make sense!

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered

Re: WLC 5508 to C6509 etherchannel problem

Im going to offer my 2cents?

First. why are you using a native VLAN on the WLC for management ? It is in your best interest to TAG all your VLANs. The Cisco manuals have noted for years to native the management, but Cisco folks will tell you this is not ideal. In fact, you will lose all QoS trust if you use mls qos trust on the WLC / switch port. Since your management is native, your capwap tunnels qos will not be trusted.

I would tagg everything .. Dont use native

In 7.x config guide it finally was changed and it states to tag your management traffic.

__________________________________________________________________________________________ "Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin ___________________________________________________________

Re: WLC 5508 to C6509 etherchannel problem

@George

I'm aware that in the switching world - native vlan is not recommended for the mgmt vlan (vlan double tagging/..)

Tagging of management traffic - losing QoS tag --> is it possible then to tag management traffic on the WLC (thus not by a switch)?

4703
Views
5
Helpful
16
Replies