Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WLC discovery using DNS

Hi

Has anyone successfully got AP's discovering the WLC using the DNS name CISCO-LWAPP-CONTROLLER?

I cant seem to get the dns server to work properly. I added a host called CISCO-LWAPP-CONTROLLER but it keeps appending the domain name to the end of it. I notice that the documentation states the discovery looks for CISCO-LWAPP-CONTROLLER@localdomain

I'm using MS DNS server. Can anyone help or provide a screenshot of the correct setup on dns.

Thanks.

  • Other Wireless - Mobility Subjects
3 REPLIES
New Member

Re: WLC discovery using DNS

I've setup the DNS name and let it use my local domain, which it does if you don't specify it. It has worked fine.

Just add the A record of cisco-lwapp-controller with the Management IP Address of the controller. It has to be the management, not the AP manager interface. DNS domain should have no relevance. I haven't seen any reference to DNS domain on a WLC.

I've set this up for several clients and it works every time. Common mistake is using the AP Mgr interface address.

New Member

Re: WLC discovery using DNS

I was curious about the same issue, and ran across this document: www.cos-cug.org/Presentations/Wireless.ppt

It seems to suggest that you put the entry in as:

cisco-lwapp-controller.localdomain

I have an Infoblox DNS appliance, and plan to try this, as well as your suggestion.

Thanks.

New Member

Re: WLC discovery using DNS

It was the .localdomain part causing me problems. When I captured packets I noticed that the AP was querying DNS for CISCO-LWAPP-CONTROLLER and the DNS respone was "not found". NSLOOKUP from a client gave the same response, but clients in the Active Directory domain resolved the address.

I added the DHCP option DOMAIN NAME with the name of my AD domain. The AP then queried for CISCO-LWAPP-CONTROLLER.test.co.uk and this worked.

So I summary I had

DHCP scope for AP's.

DNS servers in options

Defailt Gateway in options

Domain Name in options

2364
Views
0
Helpful
3
Replies
This widget could not be displayed.