Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

WLC2504 no GUI after upgrade to 7.5.102

Hi today I tried to upgrade software on my WLC2504 from 7.4.100 to 7.5.102 via GUI interface.

I disabled all my WLANs.

I downloaded image 7.5 with no errors, reboot device and watching console the WLC boot to new image with no errors. The CLI connection work, I was able to login asbefore but the web interface stop working, I had no respond via http or https.

Do you have any suggestion how to troubleshoot it? I had no problem in the past when I upgrade from 7.3 to 7.4

Below is my WLC sysinfo.

           

Primary Boot Image............................... 7.5.102.0

Backup Boot Image................................ 7.4.100.0 (default) (active)

Manufacturer's Name.............................. Cisco Systems Inc.

Product Name..................................... Cisco Controller

Product Version.................................. 7.4.100.0

Bootloader Version............................... 1.0.16

Field Recovery Image Version..................... 1.0.0

Firmware Version................................. PIC 16.0

Build Type....................................... DATA + WPS

System Name...................................... WLC-2504

System Location..................................

System Contact...................................

System ObjectID.................................. 1.3.6.1.4.1.9.1.1279

Last Reset....................................... Software reset

System Up Time................................... 0 days 1 hrs 42 mins 31 secs

System Timezone Location.........................

System Stats Realtime Interval................... 5

System Stats Normal Interval..................... 180

Configured Country............................... US  - United States

Operating Environment............................ Commercial (0 to 40 C)

Internal Temp Alarm Limits....................... 0 to 65 C

Internal Temperature............................. +27 C

External Temperature............................. +31 C

Fan Status....................................... 4300 rpm

State of 802.11b Network......................... Enabled

State of 802.11a Network......................... Enabled

Number of WLANs.................................. 2

Number of Active Clients......................... 41

Memory Current Usage............................. Unknown

Memory Average Usage............................. Unknown

CPU Current Usage................................ Unknown

CPU Average Usage................................ Unknown

Maximum number of APs supported.................. 15

     

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: WLC2504 no GUI after upgrade to 7.5.102

       

There is a workaround for this. You have to do the following configuration to get this working. It is required to reboot after this configuration

config network secureweb cipher-option rc4-preference enable

you can find the more detail in this post.

https://supportforums.cisco.com/message/4034423#4034423

"Chrome 29 adds TLS 1.2 support, and WLC is selecting a crypto suite over TLS 1.0 that apparently is breaking client"

HTH

Rasika

**** pls rate all useful responses ****

6 REPLIES
Gold

Re: WLC2504 no GUI after upgrade to 7.5.102

Hi,

Verify if HTTP is enabled with command

show network summary

If this is not enabled try emabling this with below two commands

config network webmode enable and config network secureweb enable (must reboot if you enable https)

Hope that helps

Regards

Najaf

Please rate when applicable or helpful !!!

Community Member

WLC2504 no GUI after upgrade to 7.5.102

Thanks Najaf KC

I started WLC again with 7.5 and find out that Google chrome doesn't work with new GUI interface. I tested in with Safari and works fine.

VIP Purple

Re: WLC2504 no GUI after upgrade to 7.5.102

       

There is a workaround for this. You have to do the following configuration to get this working. It is required to reboot after this configuration

config network secureweb cipher-option rc4-preference enable

you can find the more detail in this post.

https://supportforums.cisco.com/message/4034423#4034423

"Chrome 29 adds TLS 1.2 support, and WLC is selecting a crypto suite over TLS 1.0 that apparently is breaking client"

HTH

Rasika

**** pls rate all useful responses ****

Community Member

Re: WLC2504 no GUI after upgrade to 7.5.102

Tank you rasikanayanajith

It works perfect after change.

According to Wikipedia

http://en.wikipedia.org/wiki/Transport_Layer_Security#Cipher

This type of cipher "RC4" is insecure

Following post

http://www.cisco.com/en/US/docs/wireless/controller/5.2/configuration/guide/c52intf.html#wp1124863

I prefer to use

> config network secureweb cipher-option high enable
It is not supported by Chrome but gladly I have other web browsers that will support it  
I hope next update from Google Chrome will fix that.

Thank again.
VIP Purple

Re: WLC2504 no GUI after upgrade to 7.5.102

Glad that worked for you & thanks for rating the answer.

I think it is more or less Cisco has to come up with a fix in future releases to work with TLS 1.2 supported browsers without manually configuring this workaround.

Rasika

Re: WLC2504 no GUI after upgrade to 7.5.102

Thanks Rasika for sharing this useful information with community users 5+ :-).

This document was generated from the following discussion

Unable to access 5508 controller GUI with Google Chrome after upgrading to 7.5.102.0 - "SSL Connection Error"

Thanks,

Vinay Sharma

Community Manager

Thanks & Regards
793
Views
5
Helpful
6
Replies
CreatePlease to create content