Cisco Support Community
Community Member

CPAM NTP Time Not Updating

We're running CPAM version 1.5.0(0.3.17).  The time is off by about 2 hours, even though it is configured to update it's time with our NTP server.  When I log in through the web setup and attempt to update the time I get an error message saying "Date Time setup is not allowed when server is running".  

The error message doesn't seem to make much sense, how can you update the time if the server isn't running?  Anyone know how to fix this issue?  everything looks configured correctly.


(*Disclaimer - I haven't used

(*Disclaimer - I haven't used anything CPAM before)


A couple simple things I always force myself to check when troubleshooting NTP issues:

- Is your Timezone information set correctly (doubly so if it observes DST)?

- Manually set the clock to the approximate proper datetime *before* turning on NTP.


The error message you are receiving is probably implying the _NTP Server_ specifically in this case.  i.e. - It won't allow you to update the datetime manually, because it's already been instructed to maintain this value with NTP.  Try turning off NTP, or setting the clock back to manual, before trying to update the proper date and time yourself.  *Then* flip it back to NTP.


Sometimes, if the clocks are much too far out of sync, NTP can't properly sync them back up.  You mentioned only a couple hours, and this really shouldn't be a problem with NTP... but it doesn't hurt to get closer manually first.


Best of luck,



Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web:
Community Member

I would try this but I don't

I would try this but I don't want to fubar the system.  Some things go screwy if the time is messed with and the error message seems a bit ominous, like the server might need rebooted for any changes to be made.  There are also multiple places to set the NTP server, but the only place that shows the current time and allows NTP to be enabled/disabled is in the system settings from the web login.  

If it was off by an exact amount I would assume incorrect timezone settings, but it's about 1hr and 50 minutes behind so it just seems it isn't syncing with the NTP server correctly - or at least it may have initially but isn't updating.

Community Member

That warning message you are

That warning message you are getting when trying to set the NTP settings through the Web interface can be a little Confusing. When it says that it is not allowed while server is running what it is actually telling you that it will not allow you to change the NTP settings while the cisco CPAM services are running.

If you go to the monitoring page there is a stop button next to the CPAM status. This will stop the CPAM services and then you will be allowed to change the NTP settings.

Once you have changed the settings and saved make sure you go back to the monitoring page and Start the CPAM services again.


Also Each gateway has an time zone setting that can be configured.

If you are on version 1.5 you can double click on the Gateway under the Access GW Driver to access the gateway and then select properties. You can select the gateways time zone and Daylight savings options.


CreatePlease to create content