Cisco Support Community
Community Member

Lost my IOS on my cisco 2501 router "Yeah" Lost! Help!!!


I'm a newbe with certs and no real experience. I set up a home network and lab in order to work on real world skills. I installed TFTP server on a remote pc. Then I did a "copy flash tftp". The copy went well. Then I configured my 2501 router to "boot system tftp". However, when I copied the IOS, I saved it as "c2500-11.2", leaving out the rest of the spelling.

When I attempt to boot from tftp I get a lot of warnings about "illeagle ip keywords -nat, and illeagle ip keyword classless,http,access-list, etc. The boot fails and lands at the ">" prompt. I use the commands >o/r 0x2101 or >0x2102  and >I to get to a this prompt "Router3(boot)>". Nothing I do from this point gets me to a normal login prompt.

I tried installing  12.1 IOS, which shows up in my running-config, even though I get a "buffer overrun" message when I attempt to to "copy tftp flash"  using the 12.1. But nothing get me beyond that R3(boot)> / R3(boot)# . I have tried setting the registry at 0x2142 and 0x2102.

At one point I almost used the "Router3(boot)# write memory" command. But the warning about overwriting NVRAM with an inferior bootstrap scared me away. I don't know if I should ignore that warning and just do it or not.  Please help.

I see some are upgrading to 12.2 and adding flash memory.


CreatePlease to create content