Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Upgrade to VSM 7.2 error

Trying to upgrade from 7.0.0 and 7.0.1 to 7.2 and when I choose the file and select upgrade, after a few minutes I get an error Operation Failed: invalid file upload request, uploaded file could not be parsed.

2 questions :

Can the zip file be uploaded to the server and the upgrade be done using CLI?

If I choose to use ftp server, can I copy the file to the redhat server in the tftp boot folder and load it from there?

Any help would be greatly appreciated.

Thanks,

Robert                  

Everyone's tags (3)
6 REPLIES
New Member

Re: Upgrade to VSM 7.2 error

Yes, you may use the CLI for the upgrade, however, they stopped publishing the CLI method to stop us from doing it the "easy" way, lol.  And good luck with ftp server method as it seems to not always work, with Microsoft at least, however i found a quicker way to do camera firmwares (maybe related) is to already have the files on the server in the uploads directory, the webpage starts the file transfer process and immediately finishes as the file already exists.

Several ways to to check your file, run a 7zip check on it, or check MD5s etc.  Make sure the file is in the original correct format to use at the time of uploading.

New Member

Re: Upgrade to VSM 7.2 error

Okay, tried to do a cli upgrade like I am used to, however, there is a newer version of Java on 7.2.  When I tried to do it the old way and then install the new version, I get this error : 

     file /etc/init.d/jexec from install of jre-1.7.0_17-fcs conflicts with file from package jre-1.6.0_17-fcs

I'm not sure how to get rid of the fcs so I can get the new version installed.  Any help would be greatly appreciated.

Thanks,

Robert

New Member

Upgrade to VSM 7.2 error

Yes, Java installations have been ignored during the last season of upgrades as it has not revved-up/changed, but now it needs to be, obviously work with Cisco on this, but the Java upgrade procedure existed in the v6 upgrades, follow that if you know what you're doing and can adapt to RedHat from SUSE.

New Member

Upgrade to VSM 7.2 error

These were the steps I wound up using to get it done :

cd /usr/java

rm -rf java

ln -s jre-1.6.0_17 java

rpm -e jre-1.6.0_17-fcs from core directory


run /etc/init.d/cisco stop


cd /VSM72

rpm -qa | grep Cisco | xargs rpm -e


rpm -ivh jre-7u17-linux-i586.rpm

rpm -ivh Cisco_*

Thanks for the reply.

New Member

Upgrade to VSM 7.2 error

Yup, that's it, obliviously it's working for you, but are the steps out of order (just to be clear for future viewers) e.g. stop the services before, and didn't you setup the *new* java link too?

Stop services, remove old VSM rpms, remove old java rpm, remove old java link, install new java rpm, create new java link, install new VSM rpms, start services.

New Member

Upgrade to VSM 7.2 error

You are correct.  Forgot to correct the order before I posted it.  Thanks for the help.

1120
Views
0
Helpful
6
Replies
CreatePlease login to create content